summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-24 16:40:09 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-24 16:40:09 +0000
commiteee509242520acbd125aef6f164653e0bbb041f6 (patch)
tree8930717a2a95d374fbad629a1241db4463474736 /games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
parentAdded various updates from upstream. (diff)
downloadhistorical-eee509242520acbd125aef6f164653e0bbb041f6.tar.gz
historical-eee509242520acbd125aef6f164653e0bbb041f6.tar.bz2
historical-eee509242520acbd125aef6f164653e0bbb041f6.zip
Version bumped to 0.0.13 and closing bug #94366.
Package-Manager: portage-2.1_pre6-r6
Diffstat (limited to 'games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild')
-rw-r--r--games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
new file mode 100644
index 000000000000..b2548391edc2
--- /dev/null
+++ b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild,v 1.1 2006/03/24 16:40:09 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="The gtk client for the GGZ Gaming Zone"
+HOMEPAGE="http://www.ggzgamingzone.org/"
+SRC_URI="http://ftp.belnet.be/packages/ggzgamingzone/ggz/${PV}/${P}.tar.gz
+ http://mirrors.ibiblio.org/pub/mirrors/ggzgamingzone/ggz/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-games/ggz-client-libs-0.0.13
+ =x11-libs/gtk+-2*"
+
+src_compile() {
+ local myconf="--enable-gtk=gtk2"
+
+ egamesconf \
+ --enable-gtk=gtk2 \
+ --disable-debug \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
+ prepgamesdirs
+}
+