summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-12-16 12:55:51 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-12-16 12:55:51 +0000
commitf23728c053f6eaeafc3e204d2bbbbe74035a18e3 (patch)
tree16a6f04f2bb1038ecef1b5f7bb276f1fbe35e15e /games-arcade
parentrename 5.010 to 5.10 because 5.010 < 5.09 (diff)
downloadhistorical-f23728c053f6eaeafc3e204d2bbbbe74035a18e3.tar.gz
historical-f23728c053f6eaeafc3e204d2bbbbe74035a18e3.tar.bz2
historical-f23728c053f6eaeafc3e204d2bbbbe74035a18e3.zip
Force compilation with -fsigned-char to fix bug #72788 and other fixes.
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/viruskiller/ChangeLog6
-rw-r--r--games-arcade/viruskiller/Manifest15
-rw-r--r--games-arcade/viruskiller/viruskiller-0.9.ebuild12
3 files changed, 16 insertions, 17 deletions
diff --git a/games-arcade/viruskiller/ChangeLog b/games-arcade/viruskiller/ChangeLog
index 4d65d3635a20..2b251a29c4a5 100644
--- a/games-arcade/viruskiller/ChangeLog
+++ b/games-arcade/viruskiller/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/viruskiller
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.6 2004/11/22 14:25:01 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.7 2004/12/16 12:55:51 josejx Exp $
+
+ 16 Dec 2004; Joseph Jezak <josejx@gentoo.org> viruskiller-0.9.ebuild:
+ Forced compilation with -fsigned-char to fix bug #72788 and added sed check.
+ Also added dependency on pkgconfig to fix zzip-config errors.
22 Nov 2004; Karol Wojtaszek <sekretarz@gentoo.org>
viruskiller-0.9.ebuild:
diff --git a/games-arcade/viruskiller/Manifest b/games-arcade/viruskiller/Manifest
index 018623a29a20..42bd26b04943 100644
--- a/games-arcade/viruskiller/Manifest
+++ b/games-arcade/viruskiller/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 0e2439770fe334b29863757b6e9ab738 viruskiller-0.9.ebuild 1113
-MD5 de87c3f85ee6f67c0d3a8a5eb7716424 ChangeLog 913
+MD5 00d0012bd6e54c8fe0f7a98ae8db19ca ChangeLog 1126
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 16370bd373dbbf9371c9623b5a22b8f4 .ChangeLog.swp 12288
MD5 7e9b4e146dc27c68482cbda541bd9bd3 viruskiller-0.1.ebuild 1100
+MD5 ac4b556b37102cff3fb39131d659fb97 viruskiller-0.9.ebuild 1294
MD5 5a039497fd26db84e5233c78ace9db37 files/digest-viruskiller-0.1 70
MD5 7aed6b4a5ef035f812b711d9b650f0e0 files/digest-viruskiller-0.9 70
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBofbMZ/iYVBmujdURAk81AKD1uZJam03OtGoK7sp1P2tuFtMmVQCgiw06
-AW5akfrnq7NejA1JrNjoK94=
-=fwW+
------END PGP SIGNATURE-----
diff --git a/games-arcade/viruskiller/viruskiller-0.9.ebuild b/games-arcade/viruskiller/viruskiller-0.9.ebuild
index ef083ea87eb8..6b9b6b1393f6 100644
--- a/games-arcade/viruskiller/viruskiller-0.9.ebuild
+++ b/games-arcade/viruskiller/viruskiller-0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.9.ebuild,v 1.6 2004/11/22 14:25:01 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.9.ebuild,v 1.7 2004/12/16 12:55:51 josejx Exp $
-inherit games
+inherit games flag-o-matic
DESCRIPTION="Simple arcade game, shoot'em up style, where you must defend your file system from invading viruses"
HOMEPAGE="http://www.parallelrealities.co.uk/virusKiller.php"
@@ -18,7 +18,8 @@ DEPEND="media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-image
media-libs/sdl-ttf
- dev-libs/zziplib"
+ dev-libs/zziplib
+ dev-util/pkgconfig"
pkg_nofetch() {
einfo "Please download ${A} from"
@@ -32,10 +33,13 @@ src_unpack() {
sed -i \
-e "/^BINDIR = /s:/$:/bin/:" \
-e "/^DOCDIR = /s:doc/.*:doc/${PF}/html/:" \
- makefile
+ -e "s:/usr/bin/zzip-config:pkg-config zziplib:"\
+ -e "s:zzip-config:pkg-config zziplib:"\
+ makefile || die "Can't patch makefile"
}
src_compile() {
+ append-flags -fsigned-char
emake || die
}