summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-26 19:59:18 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-26 19:59:18 +0000
commit9d8285f9255cc0fd41581eca4c9447132c005791 (patch)
treef55b4b0ffd0eb7f262e56a6d720727393dd9d474 /games-arcade/pydance
parentinitial ebuild #29498 (diff)
downloadhistorical-9d8285f9255cc0fd41581eca4c9447132c005791.tar.gz
historical-9d8285f9255cc0fd41581eca4c9447132c005791.tar.bz2
historical-9d8285f9255cc0fd41581eca4c9447132c005791.zip
version bump #28782
Diffstat (limited to 'games-arcade/pydance')
-rw-r--r--games-arcade/pydance/ChangeLog47
-rw-r--r--games-arcade/pydance/files/digest-pydance-0.8.11
-rw-r--r--games-arcade/pydance/files/pydance3
-rw-r--r--games-arcade/pydance/pydance-0.8.1.ebuild42
4 files changed, 93 insertions, 0 deletions
diff --git a/games-arcade/pydance/ChangeLog b/games-arcade/pydance/ChangeLog
new file mode 100644
index 000000000000..8b837dcf258c
--- /dev/null
+++ b/games-arcade/pydance/ChangeLog
@@ -0,0 +1,47 @@
+# ChangeLog for games-arcade/pyddr
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.1 2003/09/26 19:59:18 vapier Exp $
+
+*pydance-0.8.1 (26 Sep 2003)
+
+ 26 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + games.eclass support + rename + rip out kernel module #28782.
+
+*pyddr-0.7.0 (04 Jun 2003)
+
+ 04 Jun 2003; Seemant Kulleen <seemant@gentoo.org> pyddr-0.7.0.ebuild:
+ version bump
+
+*pyddr-0.6.5 (30 May 2003)
+
+ 30 May 2003; Seemant Kulleen <seemant@gentoo.org> pyddr-0.6.0.ebuild,
+ pyddr-0.6.2.ebuild, pyddr-0.6.5.ebuild:
+ version bump
+
+ 25 May 2003; Seemant Kulleen <seemant@gentoo.org> :
+ version bump to latest
+
+*pyddr-0.6.2 (13 May 2003)
+
+ 13 May 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump, fixes and cleanups.
+
+*pyddr-0.6.0 (28 Mar 2003)
+
+ 28 Mar 2003; Joachim Blaabjerg <styx@gentoo.org> pyddr-0.6.0.ebuild
+ ChangeLog files/digest-pyddr-0.6.0 :
+
+ Updated ebuild to version 0.6.0, and changed the /usr/bin/pyddr script
+ to not suppress console output. Slap me if that was wrong. Marked ~x86
+
+*pyddr-0.5.9 (05 Mar 2003)
+
+ 04 Mar 2003; Seemant Kulleen <seemant@gentoo.org> pyddr-0.5.9.ebuild:
+ added pkg_config to compile and install the ddrmat kernel module
+
+ 05 Mar 2003; Seemant Kulleen <seemant@gentoo.org> pyddr-0.5.9.ebuild
+ ChangeLog files/digest-pyddr-0.5.9 :
+
+ New PyDDR game. This is version 0.5.9 which contains some slight
+ enhancements that P2E passed to us (over 0.5.8). Since this is not an
+ official release, we are mirroring on gentoo mirrors.
diff --git a/games-arcade/pydance/files/digest-pydance-0.8.1 b/games-arcade/pydance/files/digest-pydance-0.8.1
new file mode 100644
index 000000000000..8f0a258bb88b
--- /dev/null
+++ b/games-arcade/pydance/files/digest-pydance-0.8.1
@@ -0,0 +1 @@
+MD5 ffc7794a19208442db5ae040e9e9081e pydance-0.8.1.tar.gz 2174360
diff --git a/games-arcade/pydance/files/pydance b/games-arcade/pydance/files/pydance
new file mode 100644
index 000000000000..1b043a73ebe0
--- /dev/null
+++ b/games-arcade/pydance/files/pydance
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec python pydance.py "$@"
diff --git a/games-arcade/pydance/pydance-0.8.1.ebuild b/games-arcade/pydance/pydance-0.8.1.ebuild
new file mode 100644
index 000000000000..96586285598b
--- /dev/null
+++ b/games-arcade/pydance/pydance-0.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/pydance-0.8.1.ebuild,v 1.1 2003/09/26 19:59:18 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Dance Dance Revolution! You need this game more than Frozen Bubble"
+HOMEPAGE="http://www.icculus.org/pyddr/"
+SRC_URI="http://www.icculus.org/pyddr/${P}.tar.gz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="x86"
+
+RDEPEND="dev-python/pygame
+ media-libs/libvorbis
+ media-libs/sdl-mixer"
+PDEPEND="games-arcade/pydance-songs"
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+ insinto ${dir}
+ doins *.py
+ cp -R {sound,images,utils,themes} ${D}/${dir}/
+
+ insinto ${GAMES_SYSCONFDIR}/${PN}
+ newins pydance.posix.cfg
+
+ dogamesbin ${FILESDIR}/pydance
+ dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/pydance
+
+ dodoc BUGS CREDITS ChangeLog HACKING README TODO
+ dohtml docs/README.html
+ doman docs/man/*
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo "Emerge the games-arcade/ddrmat package to install"
+ einfo "the ddrmat kernel module, which allows you to use"
+ einfo "a DDR mat with pydance."
+}