summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 20:19:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 20:19:14 +0000
commiteada74d206d7f0116746b9f7a5cd55223766f46e (patch)
tree92f6d0d5b6b801578b0d4a0b4cda131fd54f02b6 /games-arcade/gunocide2ex
parent2.4.23 just released, bump (diff)
downloadhistorical-eada74d206d7f0116746b9f7a5cd55223766f46e.tar.gz
historical-eada74d206d7f0116746b9f7a5cd55223766f46e.tar.bz2
historical-eada74d206d7f0116746b9f7a5cd55223766f46e.zip
actually compile; depend on sed-4; more error checking/messages; tidy
Diffstat (limited to 'games-arcade/gunocide2ex')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog5
-rw-r--r--games-arcade/gunocide2ex/Manifest4
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild48
3 files changed, 33 insertions, 24 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
index bc19f818e67d..a5d5e2c1d5e1 100644
--- a/games-arcade/gunocide2ex/ChangeLog
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/gunocide2ex
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.1 2003/11/14 17:12:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.2 2003/11/28 20:19:12 mr_bones_ Exp $
+
+ 28 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> gunocide2ex-1.0.ebuild:
+ actually compile; depend on sed-4; more error checking/messages; tidy
*gunocide2ex-1.0 (14 Nov 2003)
diff --git a/games-arcade/gunocide2ex/Manifest b/games-arcade/gunocide2ex/Manifest
index f36fa2117dee..dd2bd5979f76 100644
--- a/games-arcade/gunocide2ex/Manifest
+++ b/games-arcade/gunocide2ex/Manifest
@@ -1,4 +1,4 @@
+MD5 c52ccd7dd8d332426662e5c4a1679334 ChangeLog 512
+MD5 07909a321a38ba4fe78d667d7c7e5896 gunocide2ex-1.0.ebuild 1985
MD5 1a6d5cdeab6dce56efb9db9e034d7461 files/1.0-gcc3.patch 251
MD5 a8df216f4323f42f869ca3148829177c files/digest-gunocide2ex-1.0 120
-MD5 e115a3ee5a6f2cafcf4e3b361cb59894 gunocide2ex-1.0.ebuild 1607
-MD5 907ba8a8596562c058c6fd5365944879 ChangeLog 357
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index 6004a80d71be..d131196a4440 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,58 +1,64 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.1 2003/11/14 17:12:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.2 2003/11/28 20:19:12 mr_bones_ Exp $
inherit games eutils gcc
+S=${WORKDIR}
DESCRIPTION="fast-paced 2D shoot'em'up"
HOMEPAGE="http://www.polyfrag.com/content/product_gunocide.html"
SRC_URI="mirror://sourceforge/g2ex/g2ex-setup.run"
+KEYWORDS="x86"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
DEPEND="media-libs/libsdl
media-libs/sdl-ttf
- media-libs/sdl-mixer"
-
-S=${WORKDIR}
+ media-libs/sdl-mixer
+ >=sys-apps/sed-4"
src_unpack() {
unpack_makeself
- sed -i "s:-g:${CFLAGS}:" makefile
+ sed -i "s:-g:${CFLAGS}:" makefile || \
+ die "sed makefile failed"
mkdir binary
epatch ${FILESDIR}/${PV}-gcc3.patch
edos2unix config.cfg
sed -i \
-e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \
-e "s:/usr/local/games/gunocide2ex/hscore\.dat:${GAMES_STATEDIR}/${PN}-hscore.dat:" \
- src/*.{h,cpp}
+ src/*.{h,cpp} || \
+ die "sed failed"
sed -i \
-e "s:/usr/local/games:${GAMES_DATADIR}:" \
- src/*.{h,cpp} `find gfx -name '*.txt'`
+ src/*.{h,cpp} `find gfx -name '*.txt'` || \
+ die "sed failed (2)"
}
src_compile() {
cd src
local cc=$(gcc-getCXX)
for f in *.cpp ; do
- echo "${cc} ${CFLAGS} ${f}"
- ${cc} ${cflags} -c ${f} || die "couldnt compile ${f}"
+ echo "${cc} ${CFLAGS} `sdl-config --cflags` ${f}"
+ ${cc} ${cflags} `sdl-config --cflags` -c ${f} || \
+ die "couldnt compile ${f}"
done
- ${cc} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer || die "couldnt produce binary"
+ ${cc} -o ${PN} *.o -lpthread -lSDL -lSDL_ttf -lSDL_mixer || \
+ die "couldnt produce binary"
}
src_install() {
- dogamesbin src/${PN}
- dosym ${PN} ${GAMES_BINDIR}/g2ex
- dodir ${GAMES_DATADIR}/${PN}
- cp -r gfx sfx lvl credits arial.ttf ${D}/${GAMES_DATADIR}/${PN}/
- insinto ${GAMES_SYSCONFDIR}
- newins config.cfg ${PN}.cfg
- insinto ${GAMES_STATEDIR}
- newins hscore.dat ${PN}-hscore.dat
- dodoc README history doc/MANUAL_DE
- dohtml doc/manual_de.html
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ dosym ${PN} "${GAMES_BINDIR}/g2ex" || die "dosym failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -R gfx sfx lvl credits arial.ttf "${D}/${GAMES_DATADIR}/${PN}/" || \
+ die "cp failed"
+ insinto "${GAMES_SYSCONFDIR}"
+ newins config.cfg ${PN}.cfg || die "newins failed (cfg)"
+ insinto "${GAMES_STATEDIR}"
+ newins hscore.dat ${PN}-hscore.dat || die "newins failed (hscore)"
+ dodoc history doc/MANUAL_DE || die "dodoc failed"
+ dohtml doc/manual_de.html || die "dohtml failed"
prepgamesdirs
}