summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-13 08:39:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-13 08:39:22 +0000
commit91e00a3171d6b191629734e7815a1334a4efd6a0 (patch)
treefb9b50a873caccb534bdc71927de7eeda5ec1020 /games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild
parentorig for games-arcade/barbarian-bin (diff)
downloadhistorical-91e00a3171d6b191629734e7815a1334a4efd6a0.tar.gz
historical-91e00a3171d6b191629734e7815a1334a4efd6a0.tar.bz2
historical-91e00a3171d6b191629734e7815a1334a4efd6a0.zip
initial commit - ebuild by Alexandru Toma via bug #60524
Diffstat (limited to 'games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild')
-rw-r--r--games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild b/games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild
new file mode 100644
index 000000000000..dab1004ef0a3
--- /dev/null
+++ b/games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/barbarian-bin/barbarian-bin-1.01.ebuild,v 1.1 2004/12/13 08:39:22 mr_bones_ Exp $
+
+inherit games
+
+MY_PN=${PN/-bin/}
+DESCRIPTION="Save Princess Mariana through one-on-one battles with demonic barbarians."
+HOMEPAGE="http://members.home.nl/tdbsoft/"
+SRC_URI="http://www.pcpages.com/tomberrr/downloads/${MY_PN}${PV/./}_linux.zip"
+
+LICENSE="CCPL-Attribution-NonCommercial-NoDerivs-2.0"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=media-libs/libsdl-1.2"
+
+S="${WORKDIR}"
+
+src_install() {
+ local game_dest="${GAMES_PREFIX_OPT}/${MY_PN}"
+
+ dodir "${game_dest}"
+ cp -r gfx sounds "${D}${game_dest}/" || die "cp gfx sounds failed"
+
+ exeinto "${game_dest}"
+ doexe Barbarian || die "doexe failed"
+
+ dohtml Barbarian.html || die "dohtml failed"
+
+ games_make_wrapper barbarian ./Barbarian "${game_dest}"
+
+ # High-score file
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/heroes.hoh"
+ fperms 660 "${GAMES_STATEDIR}/heroes.hoh"
+ dosym "${GAMES_STATEDIR}/heroes.hoh" "${game_dest}/heroes.hoh"
+
+ prepgamesdirs
+}