summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-28 05:53:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-28 05:53:02 +0000
commitdef06badf0920a6f9dd58f55a316b0078c80cfec (patch)
treea5a10e547a6db20d94069b827d1b44495679ccda /games-action
parentclean extra ebuild (diff)
downloadhistorical-def06badf0920a6f9dd58f55a316b0078c80cfec.tar.gz
historical-def06badf0920a6f9dd58f55a316b0078c80cfec.tar.bz2
historical-def06badf0920a6f9dd58f55a316b0078c80cfec.zip
IUSE fix; use sed -i; error check
Diffstat (limited to 'games-action')
-rw-r--r--games-action/raptor2/ChangeLog6
-rw-r--r--games-action/raptor2/Manifest4
-rw-r--r--games-action/raptor2/raptor2-1.0.0-r1.ebuild16
3 files changed, 16 insertions, 10 deletions
diff --git a/games-action/raptor2/ChangeLog b/games-action/raptor2/ChangeLog
index 717f8a773e1d..a93f542040c0 100644
--- a/games-action/raptor2/ChangeLog
+++ b/games-action/raptor2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/raptor2
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/raptor2/ChangeLog,v 1.5 2004/03/28 05:49:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/raptor2/ChangeLog,v 1.6 2004/03/28 05:53:02 mr_bones_ Exp $
+
+ 27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ raptor2-1.0.0-r1.ebuild:
+ IUSE fix; use sed -i; error check
27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> raptor2-1.0.0.ebuild:
clean extra ebuild
diff --git a/games-action/raptor2/Manifest b/games-action/raptor2/Manifest
index 6cbdd6059bef..431729d3de45 100644
--- a/games-action/raptor2/Manifest
+++ b/games-action/raptor2/Manifest
@@ -1,5 +1,5 @@
-MD5 f6943178c5f867bd3cf6a2a74e810339 ChangeLog 926
-MD5 b5596108164e8ed702052375402f7feb raptor2-1.0.0-r1.ebuild 878
+MD5 3879475547ef076fd0239d04b4894a39 ChangeLog 1045
+MD5 0de5358467c7dcd06f847fa5095db370 raptor2-1.0.0-r1.ebuild 994
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 563987e822f08af130b65e3862776d6c files/1.0.0-chdir.patch 291
MD5 ee85df7f290384c5b32e7aa0f1ff1bc5 files/digest-raptor2-1.0.0-r1 65
diff --git a/games-action/raptor2/raptor2-1.0.0-r1.ebuild b/games-action/raptor2/raptor2-1.0.0-r1.ebuild
index f6c1f8321f3e..894844360c70 100644
--- a/games-action/raptor2/raptor2-1.0.0-r1.ebuild
+++ b/games-action/raptor2/raptor2-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/raptor2/raptor2-1.0.0-r1.ebuild,v 1.4 2004/03/19 17:49:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/raptor2/raptor2-1.0.0-r1.ebuild,v 1.5 2004/03/28 05:53:02 mr_bones_ Exp $
inherit eutils games
@@ -12,10 +12,12 @@ SRC_URI="mirror://sourceforge/raptorv2/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~alpha ~ia64"
-IUSE="oggvorbis nls"
+IUSE=""
RDEPEND=">=media-libs/allegro-4.0.0
>=media-libs/aldumb-0.9.2"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
S=${WORKDIR}/${MY_P}
@@ -23,14 +25,14 @@ src_unpack() {
unpack ${A} && cd ${S}
epatch ${FILESDIR}/${PV}-chdir.patch
sed -i \
- "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" \
- src/raptor.cpp
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}/:" src/raptor.cpp \
+ || die "sed src/raptor.cpp failed"
}
src_install() {
- dogamesbin src/raptor
- insinto ${GAMES_DATADIR}/${PN}/data
- doins data/*
+ dogamesbin src/raptor || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed"
dodoc AUTHORS ChangeLog README NEWS
prepgamesdirs
}