summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-08-31 19:52:05 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-08-31 19:52:05 +0000
commit95ca99c8135b7444254ccb02d7463b74af575cef (patch)
treec33a4a24c67bd4183a4290a1b1fc7a44b8dbd7e1 /games-action
parentAdd back sip-3.8* as it's needed by PyQt-3.8.1. (diff)
downloadhistorical-95ca99c8135b7444254ccb02d7463b74af575cef.tar.gz
historical-95ca99c8135b7444254ccb02d7463b74af575cef.tar.bz2
historical-95ca99c8135b7444254ccb02d7463b74af575cef.zip
Fixed gcc-3.4 compile problems
Diffstat (limited to 'games-action')
-rw-r--r--games-action/maelstrom/ChangeLog6
-rw-r--r--games-action/maelstrom/Manifest5
-rw-r--r--games-action/maelstrom/files/maelstrom-gcc34.patch30
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6-r1.ebuild5
4 files changed, 42 insertions, 4 deletions
diff --git a/games-action/maelstrom/ChangeLog b/games-action/maelstrom/ChangeLog
index 32c3b8ec46f6..e2267cb6ca05 100644
--- a/games-action/maelstrom/ChangeLog
+++ b/games-action/maelstrom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/maelstrom
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.10 2004/06/24 21:56:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.11 2004/08/31 19:52:05 sekretarz Exp $
+
+ 31 Aug 2004; Karol Wojtaszek <sekretarz@gentoo.org>
+ maelstrom-3.0.6-r1.ebuild:
+ Fixed gcc-3.4 compile problems
19 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org> maelstrom-3.0.5.ebuild,
maelstrom-3.0.6-r1.ebuild, maelstrom-3.0.6.ebuild:
diff --git a/games-action/maelstrom/Manifest b/games-action/maelstrom/Manifest
index 9b310f52c5a5..a2141f419792 100644
--- a/games-action/maelstrom/Manifest
+++ b/games-action/maelstrom/Manifest
@@ -1,8 +1,9 @@
MD5 341a6dda71cd35a1cc1ce9d87bc50f15 maelstrom-3.0.5.ebuild 661
MD5 55ea62891e367fb22bf23c7e371e6180 maelstrom-3.0.6.ebuild 1086
-MD5 0be661f4b863b7e0db67fe476d376c62 maelstrom-3.0.6-r1.ebuild 1834
-MD5 33a91b7f346b45e214a6346d55d76934 ChangeLog 1721
+MD5 a478644fb25757e86bb936aca0b5c641 maelstrom-3.0.6-r1.ebuild 1888
+MD5 26233109945010b1c6556f5e68b75c2c ChangeLog 1839
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 fc36cbee1c4fbf10dc66ac7a2caf0428 files/maelstrom-gcc34.patch 878
MD5 5ea58949614a6eab777bda186f607f03 files/maelstrom-3.0.6-security.patch 14189
MD5 e3ab80b2fbf8ddabc7817b0fbb6a3068 files/digest-maelstrom-3.0.6-r1 68
MD5 5ea58949614a6eab777bda186f607f03 files/maelstrom-3.0.6-r1-security.patch 14189
diff --git a/games-action/maelstrom/files/maelstrom-gcc34.patch b/games-action/maelstrom/files/maelstrom-gcc34.patch
new file mode 100644
index 000000000000..6ceb421f16ba
--- /dev/null
+++ b/games-action/maelstrom/files/maelstrom-gcc34.patch
@@ -0,0 +1,30 @@
+diff -ur Maelstrom-3.0.6-orig/buttonlist.h Maelstrom-3.0.6/buttonlist.h
+--- Maelstrom-3.0.6-orig/buttonlist.h 2004-08-28 01:43:55.867378220 -0400
++++ Maelstrom-3.0.6/buttonlist.h 2004-08-28 01:44:23.700062593 -0400
+@@ -16,7 +16,7 @@
+
+ void Add_Button(Uint16 x, Uint16 y, Uint16 width, Uint16 height,
+ void (*callback)(void)) {
+- struct button *belem;
++ button *belem;
+
+ for ( belem=&button_list; belem->next; belem=belem->next );
+ belem->next = new button;
+@@ -30,7 +30,7 @@
+ }
+
+ void Activate_Button(Uint16 x, Uint16 y) {
+- struct button *belem;
++ button *belem;
+
+ for ( belem=button_list.next; belem; belem=belem->next ) {
+ if ( (x >= belem->x1) && (x <= belem->x2) &&
+@@ -42,7 +42,7 @@
+ }
+
+ void Delete_Buttons(void) {
+- struct button *belem, *btemp;
++ button *belem, *btemp;
+
+ for ( belem=button_list.next; belem; ) {
+ btemp = belem;
diff --git a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
index 8ce608b59a25..5df50550e243 100644
--- a/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
+++ b/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.5 2004/06/24 21:56:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6-r1.ebuild,v 1.6 2004/08/31 19:52:05 sekretarz Exp $
inherit eutils games
@@ -26,6 +26,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-security.patch
+ # gcc-34 fix
+ epatch ${FILESDIR}/${PN}-gcc34.patch
+
# Install the data into $(datadir)/..., not $(prefix)/games/...
sed -i \
-e "s:(prefix)/games/:(datadir)/:" configure || \