summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-19 06:08:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-19 06:08:13 +0000
commit8b7b04d6dbd1e00d2b3fa1ccbce6859f5e85daca (patch)
treeb97f376f907b15f0feb96910957bf6c4a56b41ea /games-action
parentunmask x86 for 2.1.5 (diff)
downloadhistorical-8b7b04d6dbd1e00d2b3fa1ccbce6859f5e85daca.tar.gz
historical-8b7b04d6dbd1e00d2b3fa1ccbce6859f5e85daca.tar.bz2
historical-8b7b04d6dbd1e00d2b3fa1ccbce6859f5e85daca.zip
don't rdepend on sed
Diffstat (limited to 'games-action')
-rw-r--r--games-action/abuse_sdl/Manifest6
-rw-r--r--games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild13
2 files changed, 10 insertions, 9 deletions
diff --git a/games-action/abuse_sdl/Manifest b/games-action/abuse_sdl/Manifest
index ac88d807cf4b..7836a9b68cab 100644
--- a/games-action/abuse_sdl/Manifest
+++ b/games-action/abuse_sdl/Manifest
@@ -1,5 +1,5 @@
-MD5 96b03a58f7d8819f658506b130cf61b0 files/digest-abuse_sdl-0.7.0-r2 136
-MD5 77c3fbd4b5a493ee070b426622b0d33f files/stupid-fix.patch 301
MD5 414c7f3ad876a3194cd753469958ec41 ChangeLog 1785
-MD5 15504074522bdb5fdd467d221a3ead51 abuse_sdl-0.7.0-r2.ebuild 1569
+MD5 2a4612e56f3ad8a4761dbf397b879920 abuse_sdl-0.7.0-r2.ebuild 1594
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 96b03a58f7d8819f658506b130cf61b0 files/digest-abuse_sdl-0.7.0-r2 136
+MD5 77c3fbd4b5a493ee070b426622b0d33f files/stupid-fix.patch 301
diff --git a/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild b/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild
index 9f230e171f50..a51670bc6ee9 100644
--- a/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild
+++ b/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild,v 1.2 2004/02/20 06:13:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse_sdl/abuse_sdl-0.7.0-r2.ebuild,v 1.3 2004/04/19 06:08:13 mr_bones_ Exp $
-inherit games eutils
+inherit eutils games
DESCRIPTION="port of Abuse by Crack Dot Com"
HOMEPAGE="http://www.labyrinth.net.au/~trandor/abuse/"
@@ -13,11 +13,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
-DEPEND="virtual/x11
- >=sys-apps/sed-4
+RDEPEND="virtual/x11
>=media-libs/libsdl-1.1.6"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
-DATA=${WORKDIR}/datafiles
+DATA="${WORKDIR}/datafiles"
src_unpack() {
cd ${WORKDIR}
@@ -35,7 +36,7 @@ src_unpack() {
}
src_compile() {
- egamesconf --datadir=${GAMES_DATADIR_BASE} || die
+ egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
emake || die "emake failed"
}