summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 08:51:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-09 08:51:13 +0000
commit55b56713ca1c46c577827b5a2bbe8a3e6f9ac617 (patch)
tree4e7834f066b54dd4676e4106e6344e261f203919 /games-action
parent(no commit message) (diff)
downloadhistorical-55b56713ca1c46c577827b5a2bbe8a3e6f9ac617.tar.gz
historical-55b56713ca1c46c577827b5a2bbe8a3e6f9ac617.tar.bz2
historical-55b56713ca1c46c577827b5a2bbe8a3e6f9ac617.zip
initial commit; ebuild submitted by eGore via bug #43871 (modified)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/twobowl-tactics/ChangeLog10
-rw-r--r--games-action/twobowl-tactics/Manifest4
-rw-r--r--games-action/twobowl-tactics/files/digest-twobowl-tactics-0.51
-rw-r--r--games-action/twobowl-tactics/metadata.xml5
-rw-r--r--games-action/twobowl-tactics/twobowl-tactics-0.5.ebuild59
5 files changed, 79 insertions, 0 deletions
diff --git a/games-action/twobowl-tactics/ChangeLog b/games-action/twobowl-tactics/ChangeLog
new file mode 100644
index 000000000000..33b507e7c59c
--- /dev/null
+++ b/games-action/twobowl-tactics/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/twobowl-tactics
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/twobowl-tactics/ChangeLog,v 1.1 2004/03/09 08:51:13 mr_bones_ Exp $
+
+*twobowl-tactics-0.5 (09 Mar 2004)
+
+ 09 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ twobowl-tactics-0.5.ebuild:
+ initial commit; ebuild submitted by eGore via bug #43871 (modified)
+
diff --git a/games-action/twobowl-tactics/Manifest b/games-action/twobowl-tactics/Manifest
new file mode 100644
index 000000000000..902eff1f9b8b
--- /dev/null
+++ b/games-action/twobowl-tactics/Manifest
@@ -0,0 +1,4 @@
+MD5 566f72f79137fb608fb91ffc4c966ee0 twobowl-tactics-0.5.ebuild 1593
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 a77f6a161af4bb06f510ad901d94b92b ChangeLog 447
+MD5 cfa388127da9669f2fdc08df6cc8f8db files/digest-twobowl-tactics-0.5 61
diff --git a/games-action/twobowl-tactics/files/digest-twobowl-tactics-0.5 b/games-action/twobowl-tactics/files/digest-twobowl-tactics-0.5
new file mode 100644
index 000000000000..6386e0ff4842
--- /dev/null
+++ b/games-action/twobowl-tactics/files/digest-twobowl-tactics-0.5
@@ -0,0 +1 @@
+MD5 049b3901cf166f740902a9f89a771e40 tbt.0.5.src.zip 5321239
diff --git a/games-action/twobowl-tactics/metadata.xml b/games-action/twobowl-tactics/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/twobowl-tactics/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/twobowl-tactics/twobowl-tactics-0.5.ebuild b/games-action/twobowl-tactics/twobowl-tactics-0.5.ebuild
new file mode 100644
index 000000000000..bcc22a834afe
--- /dev/null
+++ b/games-action/twobowl-tactics/twobowl-tactics-0.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/twobowl-tactics/twobowl-tactics-0.5.ebuild,v 1.1 2004/03/09 08:51:13 mr_bones_ Exp $
+
+inherit eutils games
+
+S="${WORKDIR}/tbt/src"
+DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
+HOMEPAGE="http://www.towbowltactics.com/index_en.html"
+SRC_URI="http://www.towbowltactics.com/download/tbt.${PV}.src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND="virtual/glibc
+ >=dev-libs/libxml2-2.6.6
+ >=media-libs/smpeg-0.4.4
+ >=media-libs/sdl-net-1.2.5
+ >=media-libs/sdl-image-1.2.3
+ >=media-libs/sdl-mixer-1.2.5"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ local f
+
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s/<language>0/<language>1/g" ../config.xml \
+ || die "sed config.xml failed"
+ sed -i \
+ -e "/^CFLAGS/ s:-O2 -g -fno-strength-reduce -Wall -W:${CFLAGS}:" \
+ -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" Main.cpp \
+ || die "sed Main.cpp failed"
+ sed -i \
+ -e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
+ global.h || die "sed global,h failed"
+
+ for f in `find ${S} -type f`
+ do
+ edos2unix ${f}
+ done
+}
+
+src_install() {
+ dogamesbin tbt || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/tbt"
+ cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die "cp failed"
+ insinto "${GAMES_SYSCONFDIR}/tbt"
+ doins ../config.xml || die "doins failed"
+ prepgamesdirs
+}