summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-05-12 21:44:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-05-12 21:44:18 +0000
commit1e2c674109a349955a49eb532b8391549c19b1e2 (patch)
treebe71dbb92aeacb74455217909b140b113096ab0c /games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
parentRemoving mutantstormdemo in preparation for move to mutantstorm-demo (diff)
downloadhistorical-1e2c674109a349955a49eb532b8391549c19b1e2.tar.gz
historical-1e2c674109a349955a49eb532b8391549c19b1e2.tar.bz2
historical-1e2c674109a349955a49eb532b8391549c19b1e2.zip
Moved from mutantstormdemo to mutantstorm-demo to match naming conventions.
Diffstat (limited to 'games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild')
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
new file mode 100644
index 000000000000..b479352941a3
--- /dev/null
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.1 2004/05/12 21:44:18 wolf31o2 Exp $
+
+inherit games eutils
+
+DESCRIPTION="shoot through crazy psychedelic 3D environments"
+HOMEPAGE="http://www.pompom.org.uk/"
+SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ cp -r menu script styles ${D}/${dir}/
+
+ exeinto ${dir}
+ doexe bin/Linux/x86/*
+ dosym ${dir}/mutantstormdemo ${GAMES_BINDIR}/mutantstorm-demo
+
+ insinto ${dir}
+ doins README.txt buy_me mutant.xpm pompom readme.htm
+
+ prepgamesdirs
+}