summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-18 18:35:30 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-18 18:35:30 +0000
commit980cdd8b0adc9a111806f486722e9a9b7de36277 (patch)
tree8bafbdb1515a0d7bd8be621e9a7ad5ddb39b5f08 /eclass
parentremove mask of kde children ebuilds, since the ebuilds have been removed (diff)
downloadhistorical-980cdd8b0adc9a111806f486722e9a9b7de36277.tar.gz
historical-980cdd8b0adc9a111806f486722e9a9b7de36277.tar.bz2
historical-980cdd8b0adc9a111806f486722e9a9b7de36277.zip
remove kde-child,parent.eclass since no ebuilds use them anymore. avoid cluttering.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde-child.eclass112
-rw-r--r--eclass/kde-parent.eclass29
2 files changed, 0 insertions, 141 deletions
diff --git a/eclass/kde-child.eclass b/eclass/kde-child.eclass
deleted file mode 100644
index cb52a1c7a4c6..000000000000
--- a/eclass/kde-child.eclass
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-child.eclass,v 1.2 2002/07/12 15:24:36 danarmak Exp $
-# Inherited by children ebuilds, which must specify their $PARENT ebuild before inheriting.
-ECLASS=kde-child
-INHERITED="$INHERITED $ECLASS"
-#TODO: prevent $S/README, etc. from being dodoc'd
-
-# determine settings
-# Rename to $SIBLINGS? :-)
-[ -z "$SUBDIRS" ] && SUBDIRS="$PN doc"
-
-if [ -z "$PARENT" ]; then
- einfo "!!! $ECLASS: error: kde-child sourced, but \$PARENT not defined. Please report this bug."
- exit 1
-fi
-
-debug-print "$ECLASS: beginning, PARENT=$PARENT, SUBDIRS=$SUBDIRS"
-
-# source parent ebuild
-debug-print "$ECLASS: sourcing ${PORTDIR}/${PARENT}"
-source "/usr/portage/${PARENT}"
-
-ECLASS=kde-child
-DESCRIPTION="Based on the $ECLASS eclass"
-
-# no master-side src_unpack mods allowed atm
-kde-child_src_unpack () {
-
- base_src_unpack
-
- cd ${S}
- # convert spaces to newlines
- mv subdirs subdirs.orig
- for x in $SUBDIRS; do
- debug-print "$FUNCNAME: parsing \$SUBDIRS: adding $x to subdirs"
- echo $x >> subdirs
- done
- rm subdirs.orig
-
- # we always do this, but it won't take effect unless doc is in $SUBDIRS!
- if [ -d doc ]; then
- cd doc
- DOCSUBDIRS=""
- for x in $SUBDIRS; do
- [ -d "$x" ] && DOCSUBDIRS="$DOCSUBDIRS $x"
- done
- debug-print "$FUNCNAME: doc subdir detected, found DOCSUBDIRS=$DOCSUBDIRS"
- mv Makefile.am Makefile.am.orig
- sed -e "s:SUBDIRS = \$(AUTOSUBDIRS):SUBDIRS = $DOCSUBDIRS:" Makefile.am.orig > Makefile.am
- mv Makefile.in Makefile.in.orig
- sed -e "s:SUBDIRS =. :SUBDIRS =. $DOCSUBDIRS \#:" Makefile.in.orig > Makefile.in
- rm Makefile.in.orig Makefile.am.orig
- fi
-
- # if asked, enable non-default packages
- if [ -n "$FORCE" ]; then
- cd ${S}
- for x in $FORCE; do
- for y in configure configure.in; do
- mv $y $y.orig
- sed -e "s:DO_NOT_COMPILE=\"\$DO_NOT_COMPILE ${x}\":\#:" $y.orig > $y
- rm $y.orig
- done
- done
- chmod +x configure
- fi
-
- # Finally, delete all top-level subdirs except for those in $SUBDIRS
- # and admin and doc. This way we both save space and locate any
- # subdir interdependencies.
- cd ${S}
- for x in *
- do
- # process all directories
- if [ -d "$x" ]; then
-
- KEEP=false
-
- # check if $x is in $SUBDIRS, if it is we should keep it
- case "$SUBDIRS admin" in
- *$x*) KEEP=true;;
- esac
-
- # remove it if we decided not to keep it
- if [ "$KEEP" == "false" ]; then
-
- debug-print "$FUNCNAME: removing subdir $x"
-
- # make sure configure doesn't try to create makefiles in the
- # directories we're removing
- echo "./admin/configure.in.min
-configure.in.in" > configure.files
- find $x -iname configure.in.in >> configure.files
-
- # finally, remove it
- rm -rf $x
- rm -rf doc/$x
-
- else
- debug-print "$FUNCNAE: keeping subdir $x"
- fi
-
- fi
- done
-
-}
-
-EXPORT_FUNCTIONS src_unpack
-
-
diff --git a/eclass/kde-parent.eclass b/eclass/kde-parent.eclass
deleted file mode 100644
index 4a50423a076b..000000000000
--- a/eclass/kde-parent.eclass
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-parent.eclass,v 1.2 2002/07/12 15:24:36 danarmak Exp $
-# Inherited by parent ebuilds, which must set their list of $CHILDREN before inheriting
-# Make sure to inherit this eclass LAST, for the empty functions below to take effect
-ECLASS=kde-parent
-INHERITED="$INHERITED $ECLASS"
-
-# Don't do anything if we're inheriting from a child ebuild
-if [ -z "$PARENT" ]; then
-
- debug-print "$ECLASS: beginning, CHILDREN=$CHILDREN"
-
- kde-parent_src_unpack() { true; }
- kde-parent_src_compile() { true; }
- kde-parent_src_install() { true; }
- kde-parent_pkg_preinst() { true; }
- kde-parent_pkg_postinst() { true; }
- kde-parent_pkg_prerm() { true; }
- kde-parent_pkg_postrm() { true; }
-
- RDEPEND="$RDEPEND $CHILDREN"
-
- EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_preinst pkg_postinst pkg_prerm pkg_postrm
-
-else
- debug-print "$ECLASS: \$PARENT set (=$PARENT), child mode assumed, no action taken"
-fi