summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-01-13 21:48:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-01-13 21:48:42 +0000
commit011de37f6477fd953b1ae2895639b3669bb49f30 (patch)
treefed0189e47ece786865239494f3af4e2ff48de99 /dev-vcs/git/git-9999.ebuild
parentVersion bump. Add xz tarball support so we can upload our own release tarbal... (diff)
downloadhistorical-011de37f6477fd953b1ae2895639b3669bb49f30.tar.gz
historical-011de37f6477fd953b1ae2895639b3669bb49f30.tar.bz2
historical-011de37f6477fd953b1ae2895639b3669bb49f30.zip
Propogate libpcre change to live ebuild.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index d61f9be0bbc3..675f4cb6cbcc 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.25 2011/10/24 17:36:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.26 2012/01/13 21:48:42 robbat2 Exp $
EAPI=4
@@ -46,7 +46,7 @@ IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +
CDEPEND="
!blksha1? ( dev-libs/openssl )
sys-libs/zlib
- perl? ( dev-lang/perl[-build] )
+ perl? ( dev-lang/perl[-build] dev-libs/libpcre )
tk? ( dev-lang/tk )
curl? (
net-misc/curl
@@ -146,7 +146,7 @@ exportmakeopts() {
use tk \
|| myopts="${myopts} NO_TCLTK=YesPlease"
use perl \
- && myopts="${myopts} INSTALLDIRS=vendor" \
+ && myopts="${myopts} INSTALLDIRS=vendor USE_LIBPCRE=yes" \
|| myopts="${myopts} NO_PERL=YesPlease"
use python \
|| myopts="${myopts} NO_PYTHON=YesPlease"