summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-10-02 19:21:29 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-10-02 19:21:29 +0000
commitc1f83644ae4da39f4ee12bfb470b2cfe6abc92f3 (patch)
tree91587b6fb8e620102f92c9434d5adde24a33a6bf /dev-util
parentUpdate bmpx mask to cover entire 0.3x series. (diff)
downloadhistorical-c1f83644ae4da39f4ee12bfb470b2cfe6abc92f3.tar.gz
historical-c1f83644ae4da39f4ee12bfb470b2cfe6abc92f3.tar.bz2
historical-c1f83644ae4da39f4ee12bfb470b2cfe6abc92f3.zip
New upstream version. Remove buggy ones.
Package-Manager: portage-2.1.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog8
-rw-r--r--dev-util/git/files/digest-git-1.4.2.39
-rw-r--r--dev-util/git/git-1.4.2.3.ebuild151
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 00d8180c33f1..2123a2c35935 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.125 2006/09/30 10:40:25 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.126 2006/10/02 19:21:29 ferdy Exp $
+
+*git-1.4.2.3 (02 Oct 2006)
+
+ 02 Oct 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.2.1.ebuild,
+ -git-1.4.2.2.ebuild, +git-1.4.2.3.ebuild:
+ New upstream version. Remove buggy ones.
*git-1.4.2.2 (30 Sep 2006)
diff --git a/dev-util/git/files/digest-git-1.4.2.3 b/dev-util/git/files/digest-git-1.4.2.3
new file mode 100644
index 000000000000..35e083cf3193
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.2.3
@@ -0,0 +1,9 @@
+MD5 95edf080ae94c62ca454f79f9ad31b42 git-1.4.2.3.tar.bz2 787480
+RMD160 096f4d8a4119f858c47b3975af01a0d6a2327c3c git-1.4.2.3.tar.bz2 787480
+SHA256 9103f7fb921b9415077375e65a5482ea3ce378e6863276970630f39247f3ef8c git-1.4.2.3.tar.bz2 787480
+MD5 a45c703b7115e55061ce4064c5e202a0 git-htmldocs-1.4.2.3.tar.bz2 284058
+RMD160 8efbf6c47c0ae4f5870a744accd12aa886cb99d4 git-htmldocs-1.4.2.3.tar.bz2 284058
+SHA256 8bd698b2e346679f483b2cdf22d0f25c2430511d54e6d9a7e665654c113f5f51 git-htmldocs-1.4.2.3.tar.bz2 284058
+MD5 5df63737c0d238a7ca74c97d097729d1 git-manpages-1.4.2.3.tar.bz2 90422
+RMD160 d82dfea6381f282505b548b2d424de1f1dbad6f0 git-manpages-1.4.2.3.tar.bz2 90422
+SHA256 42e2ff53e00b5f091bc6dffad92b7a746f54b80eb4445c7b143b666087f131c8 git-manpages-1.4.2.3.tar.bz2 90422
diff --git a/dev-util/git/git-1.4.2.3.ebuild b/dev-util/git/git-1.4.2.3.ebuild
new file mode 100644
index 000000000000..e93aee91aa22
--- /dev/null
+++ b/dev-util/git/git-1.4.2.3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.3.ebuild,v 1.1 2006/10/02 19:21:29 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
+ einfo
+ einfo "If you want to import a quilt series into git, consider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}