summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-11-17 08:37:11 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-11-17 08:37:11 +0000
commit90707c6c26590a564258e9c2d1525264fbae1d06 (patch)
tree546a173994b0170d6e52f1097057fd168cecc350 /dev-util
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-90707c6c26590a564258e9c2d1525264fbae1d06.tar.gz
historical-90707c6c26590a564258e9c2d1525264fbae1d06.tar.bz2
historical-90707c6c26590a564258e9c2d1525264fbae1d06.zip
new version
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/glade/ChangeLog5
-rw-r--r--dev-util/glade/files/digest-glade-1.1.31
-rw-r--r--dev-util/glade/glade-1.1.3.ebuild48
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-util/glade/ChangeLog b/dev-util/glade/ChangeLog
index f53c06e7ad0e..032067f6442c 100644
--- a/dev-util/glade/ChangeLog
+++ b/dev-util/glade/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for dev-util/glade
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.7 2002/09/19 12:14:31 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/ChangeLog,v 1.8 2002/11/17 08:37:11 leonardop Exp $
+*glade-1.1.3 (17 Nov 2002)
+ 17 Nov 2002; L. Boshell <leonardop@gentoo.org> : New version.
+
*glade-1.1.1 (4 aug 2002)
10 Sep 2002; Olivier Reisch <doctomoe@gentoo.org> glade-1.1.1.ebuild:
Added ppc keyword
diff --git a/dev-util/glade/files/digest-glade-1.1.3 b/dev-util/glade/files/digest-glade-1.1.3
new file mode 100644
index 000000000000..212219ccb51d
--- /dev/null
+++ b/dev-util/glade/files/digest-glade-1.1.3
@@ -0,0 +1 @@
+MD5 ceb1fb626e4fa676b8b458aa422c7d22 glade-1.1.3.tar.bz2 1636809
diff --git a/dev-util/glade/glade-1.1.3.ebuild b/dev-util/glade/glade-1.1.3.ebuild
new file mode 100644
index 000000000000..440710888b6e
--- /dev/null
+++ b/dev-util/glade/glade-1.1.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-1.1.3.ebuild,v 1.1 2002/11/17 08:37:11 leonardop Exp $
+
+IUSE="nls gnome"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Glade is a GUI Builder. This release is for GTK+ 2 and GNOME 2."
+SRC_URI="mirror://gnome/sources/glade/1.1/${P}.tar.bz2"
+HOMEPAGE="http://glade.gnome.org/"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="=x11-libs/gtk+-2*
+ =dev-libs/libxml2-2.4*
+ gnome? ( >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libgnomecanvas-2.0.0
+ >=gnome-base/libbonoboui-2.0.0
+ >=gnome-base/libgnomeprint-1.114.0
+ >=gnome-base/libgnomeprintui-1.114.0 )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )
+ >=app-text/scrollkeeper-0.2"
+
+src_compile() {
+ local myconf=""
+
+ use gnome || myconf="--disable-gnome"
+ use nls || myconf="${myconf} --disable-nls"
+
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug"
+
+ econf \
+ --disable-gnome-db \
+ ${myconf} || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS COPYING* FAQ NEWS README* TODO
+}