summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-30 18:24:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-30 18:24:43 +0000
commit74456aec6624ddb12d338131d2663abe64d16ee2 (patch)
tree88b8203dd7b58460489f539ed38c1219a506760b /dev-util/skipfish/skipfish-1.27_beta.ebuild
parentuzbl-9999: various improvements, bug #310375. new vim-syntax USE. all version... (diff)
downloadhistorical-74456aec6624ddb12d338131d2663abe64d16ee2.tar.gz
historical-74456aec6624ddb12d338131d2663abe64d16ee2.tar.bz2
historical-74456aec6624ddb12d338131d2663abe64d16ee2.zip
Version bump by Alex Legler.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-util/skipfish/skipfish-1.27_beta.ebuild')
-rw-r--r--dev-util/skipfish/skipfish-1.27_beta.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/skipfish/skipfish-1.27_beta.ebuild b/dev-util/skipfish/skipfish-1.27_beta.ebuild
new file mode 100644
index 000000000000..e1847807d37d
--- /dev/null
+++ b/dev-util/skipfish/skipfish-1.27_beta.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-1.27_beta.ebuild,v 1.1 2010/03/30 18:24:43 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${P/_beta/b}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ net-dns/libidn
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug} || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl || die
+
+ dohtml assets/* || die
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}