summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-01-02 00:11:03 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-01-02 00:11:03 +0000
commita2abd6f5d7251519be8a025badb59a5343de11f8 (patch)
tree1ff12b5d15fe409f7852d5116296602972a2082e /dev-util/monotone/monotone-0.16.ebuild
parentVersion bump. (diff)
downloadhistorical-a2abd6f5d7251519be8a025badb59a5343de11f8.tar.gz
historical-a2abd6f5d7251519be8a025badb59a5343de11f8.tar.bz2
historical-a2abd6f5d7251519be8a025badb59a5343de11f8.zip
Remove broken 0.15 version. Added version 0.16 as per bug report #76332.
Diffstat (limited to 'dev-util/monotone/monotone-0.16.ebuild')
-rw-r--r--dev-util/monotone/monotone-0.16.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/monotone/monotone-0.16.ebuild b/dev-util/monotone/monotone-0.16.ebuild
new file mode 100644
index 000000000000..a91951096ca6
--- /dev/null
+++ b/dev-util/monotone/monotone-0.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.16.ebuild,v 1.1 2005/01/02 00:11:03 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/monotone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+#Target Keywords ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+
+IUSE="nls"
+# "doc"
+
+RDEPEND="virtual/libc
+ >=dev-libs/boost-1.31.0
+ dev-libs/popt"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.3.3
+ sys-devel/gettext
+ doc? ( dev-lang/perl sys-apps/texinfo )"
+
+src_compile() {
+
+ # more aggressive optimizations cause trouble with the
+ # crypto library
+ # disable stack protector
+
+ replace-flags -O3 -O2
+ append-flags -fno-stack-protector-all -fno-stack-protector -fno-strict-aliasing
+
+ econf `use_enable nls` || die
+ emake || die "emake failed"
+}
+
+src_test() {
+ einfo "self test currently broken"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ # Generate html docs
+
+ #if use doc ; then
+ # emake html || die "emake html failed"
+ # dohtml -r html/*
+ #fi
+
+ dodoc NEWS
+}