summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-27 21:38:51 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-27 21:38:51 +0000
commit3de2cb271f69e58ec45091260b9c6dfc65acd917 (patch)
tree791006944036a783a0d2931b5af7ad0b67d7af06 /dev-util/jam
parentoops (diff)
downloadhistorical-3de2cb271f69e58ec45091260b9c6dfc65acd917.tar.gz
historical-3de2cb271f69e58ec45091260b9c6dfc65acd917.tar.bz2
historical-3de2cb271f69e58ec45091260b9c6dfc65acd917.zip
gcc-2.x fix
Diffstat (limited to 'dev-util/jam')
-rw-r--r--dev-util/jam/ChangeLog9
-rw-r--r--dev-util/jam/Manifest4
-rw-r--r--dev-util/jam/jam-2.4.ebuild13
3 files changed, 16 insertions, 10 deletions
diff --git a/dev-util/jam/ChangeLog b/dev-util/jam/ChangeLog
index e4c951cd65dc..c4b022b6c79c 100644
--- a/dev-util/jam/ChangeLog
+++ b/dev-util/jam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/jam
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/ChangeLog,v 1.4 2003/04/16 02:36:57 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/ChangeLog,v 1.5 2003/04/27 21:38:51 vapier Exp $
+
+*jam-2.4 (03 Nov 2002)
+
+ 27 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added edos2unix support since gcc-2.x dies on the windows file format.
16 Apr 2003; Luca barbato <lu_zero@gentoo.org> :
added ~ppc KEYWORD
@@ -11,7 +16,5 @@
submitted an ebuild long ago, but I could just never get to
it (bug #4583).
-*jam-2.4 (03 Nov 2002)
-
03 Nov 2002; J Robert Ray <jrray@gentoo.org> :
New ebuild, submitted by Jeffrey Palmer <jeffrey.palmer@acm.org>.
diff --git a/dev-util/jam/Manifest b/dev-util/jam/Manifest
index df699c150b55..810c8f06f4a9 100644
--- a/dev-util/jam/Manifest
+++ b/dev-util/jam/Manifest
@@ -1,3 +1,3 @@
-MD5 b164d27af867bb43b51af04ae29c91ec ChangeLog 690
-MD5 72224271ca532c34514219d1777eb7bd jam-2.4.ebuild 707
+MD5 1134fc4e01327b96ea2ab8d414e8c957 jam-2.4.ebuild 791
+MD5 153d79c34b8e0a8ffd3f357e143aee0f ChangeLog 816
MD5 5fc4187fd9fbd142e33e9f924ebedb5d files/digest-jam-2.4 56
diff --git a/dev-util/jam/jam-2.4.ebuild b/dev-util/jam/jam-2.4.ebuild
index 001354d2afab..460176c915a2 100644
--- a/dev-util/jam/jam-2.4.ebuild
+++ b/dev-util/jam/jam-2.4.ebuild
@@ -1,25 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/jam-2.4.ebuild,v 1.5 2003/04/16 02:36:57 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/jam/jam-2.4.ebuild,v 1.6 2003/04/27 21:38:51 vapier Exp $
-DESCRIPTION="jam (Just Another Make) - advanced make replacement"
+inherit eutils
+
+DESCRIPTION="Just Another Make - advanced make replacement"
SRC_URI="ftp://ftp.perforce.com/pub/jam/${P}.zip"
HOMEPAGE="http://www.perforce.com/jam/jam.html"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="x86 ppc"
DEPEND="dev-util/yacc
app-arch/unzip"
src_compile() {
+ edos2unix `find -name '*.c' -o -name '*.h'`
# The bootstrap makefile assumes ${S} is in the path
- PATH="${PATH}:${S}" make || die
+ env PATH="${PATH}:${S}" make CFLAGS="${CFLAGS}" || die
}
src_install() {
- BINDIR="${D}/usr/bin" ./jam0 install
+ BINDIR="${D}/usr/bin" ./jam0 install || die
dohtml Jam.html Jambase.html Jamfile.html
dodoc README RELNOTES Porting
}