summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-03 19:25:36 +0000
commitf8759de72004af040e24839679a6ca0c77b79805 (patch)
tree231ca7751359ddd11f442ab886123631cbbd9826 /dev-util/gnustep-base
parentmask for new versions of gnustep programs (diff)
downloadhistorical-f8759de72004af040e24839679a6ca0c77b79805.tar.gz
historical-f8759de72004af040e24839679a6ca0c77b79805.tar.bz2
historical-f8759de72004af040e24839679a6ca0c77b79805.zip
Version bump on gnustep. Currently masked. This bumps all the unstable
builds to stable revisions. gcc3 is required for these packages.
Diffstat (limited to 'dev-util/gnustep-base')
-rw-r--r--dev-util/gnustep-base/ChangeLog24
-rw-r--r--dev-util/gnustep-base/files/digest-gnustep-base-1.4.01
-rw-r--r--dev-util/gnustep-base/gnustep-base-1.4.0.ebuild36
3 files changed, 48 insertions, 13 deletions
diff --git a/dev-util/gnustep-base/ChangeLog b/dev-util/gnustep-base/ChangeLog
index ad2fbf164e1d..8a47cdcad500 100644
--- a/dev-util/gnustep-base/ChangeLog
+++ b/dev-util/gnustep-base/ChangeLog
@@ -1,39 +1,37 @@
# ChangeLog for dev-util/gnustep-base
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# Author Nick Hadaway <raker@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/ChangeLog,v 1.5 2002/07/19 17:27:49 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/ChangeLog,v 1.6 2002/09/03 19:25:35 raker Exp $
+
+*gnustep-base-1.4.0 (03 Sep 2002)
+
+ 03 Sep 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.4.0.ebuild,
+ files/digest-gnustep-base-1.4.0 :
+ Version bump.
*gnustep-base-1.3.4-r1 (19 Jul 2002)
19 Jul 2002; Nick Hadaway <raker@gentoo.org>
gnustep-base-1.3.4-r1.ebuild, files/digest-gnustep-base-1.3.4-r1 :
-
Figured out install variables. No longer doing manual file install.
Fixed some typos in the ChangeLog.
-*gnustep-base-1.1.0 (07 Jul 2002)
-
- 07 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
-
- Back to the stable version. Cleaned up the ebuild and should now install
- properly.
-
*gnustep-base-1.3.4 (05 Jul 2002)
05 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.3.4.ebuild:
-
Updated to the 1.3.4 package. libxml2 now appears to be detected.
Currently fails compiling, so masked in package.mask
*gnustep-base-1.3.3 (04 Jul 2002)
04 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.3.3.ebuild:
-
Updated to the 1.3.3 package. libxml2 is currently not detected correctly.
*gnustep-base-1.1.0 (04 Jul 2002)
+ 07 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
+ Back to the stable version. Cleaned up the ebuild and should now install
+ properly.
+
04 Jul 2002; Nick Hadaway <raker@gentoo.org> gnustep-base-1.1.0.ebuild:
-
This is the first ebuild for this package. The GNUstep base package.
diff --git a/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0 b/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0
new file mode 100644
index 000000000000..07781b850415
--- /dev/null
+++ b/dev-util/gnustep-base/files/digest-gnustep-base-1.4.0
@@ -0,0 +1 @@
+MD5 2eff09a24fe02e36dc7cdf8e4f60823e gnustep-base-1.4.0.tar.gz 1572242
diff --git a/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild b/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild
new file mode 100644
index 000000000000..334e382aaa40
--- /dev/null
+++ b/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gnustep-base/gnustep-base-1.4.0.ebuild,v 1.1 2002/09/03 19:25:35 raker Exp $
+
+DESCRIPTION="GNUstep base package"
+HOMEPAGE="http://www.gnustep.org"
+LICENSE="LGPL"
+DEPEND=">=dev-util/gnustep-make-1.4.0
+ >=dev-libs/libxml2-2.4.23"
+RDEPEND="virtual/glibc"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="x86 -ppc sparc sparc64"
+SLOT="0"
+
+src_compile() {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+ econf \
+ --with-xml-prefix=/usr \
+ --with-gmp-include=/usr/include \
+ --with-gmp-library=/usr/lib || die "./configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ . /usr/GNUstep/System/Makefiles/GNUstep.sh
+
+ make install \
+ GNUSTEP_INSTALLATION_DIR=${D}/usr/GNUstep/System \
+ INSTALL_ROOT_DIR=${D} \
+ || die "install failed"
+
+}