summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-04-10 02:33:03 +0000
committerMarius Mauch <genone@gentoo.org>2004-04-10 02:33:03 +0000
commit5a08a215a723509045a83b9bb68fc7b4e58545ed (patch)
treea7aeaba811108abeca4705b8dc2338403543cf9a /dev-util/gambas
parentMarked stable on mips. (diff)
downloadhistorical-5a08a215a723509045a83b9bb68fc7b4e58545ed.tar.gz
historical-5a08a215a723509045a83b9bb68fc7b4e58545ed.tar.bz2
historical-5a08a215a723509045a83b9bb68fc7b4e58545ed.zip
patch to fix possible file corruption
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog9
-rw-r--r--dev-util/gambas/Manifest5
-rw-r--r--dev-util/gambas/files/digest-gambas-0.92-r11
-rw-r--r--dev-util/gambas/files/gbx_exec_enum-0.92.patch27
-rw-r--r--dev-util/gambas/gambas-0.92-r1.ebuild80
5 files changed, 120 insertions, 2 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 549a3b3e2b9f..ebf8e99ed878 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.10 2004/04/03 13:22:28 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.11 2004/04/10 02:33:03 genone Exp $
+
+*gambas-0.92-r1 (10 Apr 2004)
+
+ 10 Apr 2004; Marius Mauch <genone@gentoo.org> gambas-0.92-r1.ebuild,
+ files/gbx_exec_enum-0.92.patch:
+ Adding a patch from Benoit Minisini to fix tabstrip corruptions when saving
+ forms.
*gambas-0.92 (03 Apr 2004)
diff --git a/dev-util/gambas/Manifest b/dev-util/gambas/Manifest
index 67c514caa9e4..2872336edb19 100644
--- a/dev-util/gambas/Manifest
+++ b/dev-util/gambas/Manifest
@@ -1,9 +1,12 @@
MD5 dcff878e1a02621c10898637686214b2 gambas-0.91.ebuild 1867
MD5 b1d2a069841a93b222037caa7f85e44a gambas-0.92.ebuild 1868
-MD5 48eb05b38899351c70e589c746366e8f ChangeLog 2218
+MD5 b814712cc24e6c5d3e506f06bcf75e69 ChangeLog 2442
MD5 622720c5c5e309d4457ff037f8a4175f metadata.xml 222
+MD5 75435bcc939621828b1dd90001e042e5 gambas-0.92-r1.ebuild 1976
MD5 ef914d63f991882bd4c95e78c9eb069d files/info-location-0.90.patch 872
MD5 30893adf8f34f69b90fa4e9e736b579b files/non-symlink-0.90.patch 1489
MD5 59e95678efba2286221a1040cf515aa3 files/digest-gambas-0.91 65
MD5 71bcff61006d8528abb1b438a23c66f8 files/digest-gambas-0.92 65
MD5 964111dfc43bdc4aab2276817f8f57df files/Makefile.am-0.90 1370
+MD5 71bcff61006d8528abb1b438a23c66f8 files/digest-gambas-0.92-r1 65
+MD5 a7abb94385567542662526650958f5f1 files/gbx_exec_enum-0.92.patch 751
diff --git a/dev-util/gambas/files/digest-gambas-0.92-r1 b/dev-util/gambas/files/digest-gambas-0.92-r1
new file mode 100644
index 000000000000..cbd497f821a3
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-0.92-r1
@@ -0,0 +1 @@
+MD5 06641baa8c0405a9075088690eb30a67 gambas-0.92.tar.bz2 2735305
diff --git a/dev-util/gambas/files/gbx_exec_enum-0.92.patch b/dev-util/gambas/files/gbx_exec_enum-0.92.patch
new file mode 100644
index 000000000000..09acc8bec34f
--- /dev/null
+++ b/dev-util/gambas/files/gbx_exec_enum-0.92.patch
@@ -0,0 +1,27 @@
+--- src/exec/gbx_exec_enum.c.org 2004-02-28 11:46:15.000000000 +0100
++++ src/exec/gbx_exec_enum.c 2004-04-10 04:19:03.479686056 +0200
+@@ -41,8 +41,8 @@
+ local = &BP[code & 0xFF];
+
+ EXEC_object(local, &class, &object, &defined);
+- EXEC_enum_data = (void *)(local[1]._void.value);
+- memset(EXEC_enum_data, 0, 8);
++ EXEC_enum_data = (void *)(&local[1]._void.ptype);
++ memset(EXEC_enum_data, 0, 12);
+
+ EXEC_special(SPEC_FIRST, class, object, 0, TRUE);
+ }
+@@ -58,7 +58,7 @@
+ local = &BP[PC[-1] & 0xFF];
+
+ EXEC_object(local, &class, &object, &defined);
+- EXEC_enum_data = (void *)(local[1]._void.value);
++ EXEC_enum_data = (void *)(&local[1]._void.ptype);
+
+ EXEC_enum_stop = FALSE;
+
+@@ -70,3 +70,4 @@
+
+ return EXEC_enum_stop;
+ }
++
diff --git a/dev-util/gambas/gambas-0.92-r1.ebuild b/dev-util/gambas/gambas-0.92-r1.ebuild
new file mode 100644
index 000000000000..12d4b17e2867
--- /dev/null
+++ b/dev-util/gambas/gambas-0.92-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.92-r1.ebuild,v 1.1 2004/04/10 02:33:03 genone Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net"
+SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="postgres mysql sdl doc curl debug"
+
+DEPEND=">=sys-devel/automake-1.7.5
+ >=x11-base/xfree-4.3.0
+ >=x11-libs/qt-3.2
+ >=kde-base/kdelibs-3.2
+ sdl? ( media-libs/libsdl )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-misc/curl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Os::' configure
+ # replace braindead Makefile
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-0.90" ./Makefile.am
+ automake
+ # patches against hardcoded paths
+ epatch ${FILESDIR}/non-symlink-0.90.patch
+ epatch ${FILESDIR}/info-location-0.90.patch
+ # patch to fix bug with tabstrips
+ epatch ${FILESDIR}/gbx_exec_enum-0.92.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --enable-kde --enable-qt"
+ myconf="${myconf} `use_enable mysql`"
+ myconf="${myconf} `use_enable postgres`"
+ myconf="${myconf} `use_enable sdl`"
+ myconf="${myconf} `use_enable curl`"
+
+ if use debug ; then
+ myconf="${myconf} --disable-optimization --enable-debug"
+ else
+ myconf="${myconf} --enable-optimization --disable-debug"
+ fi
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ einstall || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc; then
+ mv ${D}/usr/share/help ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/examples ${D}/usr/share/doc/${PF}/examples
+ einfo "Compiling examples ..."
+ cd ${D}/usr/share/doc/${PF}/examples
+ for p in *; do
+ cd $p
+ gbc -ag
+ gba
+ cd ..
+ done
+ fi
+ rm -rf ${D}/usr/share/help ${D}/usr/share/examples
+}