summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-01-18 01:43:52 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-01-18 01:43:52 +0000
commit1cc7f8f60380cc6f05d951ab03da5393556f3876 (patch)
tree868ed688bc81c86c06a4be6715cdbd59b26a3959 /dev-util/eric
parentVersion bump, fixed deps (diff)
downloadhistorical-1cc7f8f60380cc6f05d951ab03da5393556f3876.tar.gz
historical-1cc7f8f60380cc6f05d951ab03da5393556f3876.tar.bz2
historical-1cc7f8f60380cc6f05d951ab03da5393556f3876.zip
Version bump, fixed deps
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/Manifest4
-rw-r--r--dev-util/eric/eric-3.2.ebuild4
-rw-r--r--dev-util/eric/eric-3.3.1.ebuild60
-rw-r--r--dev-util/eric/files/digest-eric-3.3.11
-rw-r--r--dev-util/eric/files/install.py.eric-3.3.1.diff36
5 files changed, 101 insertions, 4 deletions
diff --git a/dev-util/eric/Manifest b/dev-util/eric/Manifest
index 2091b42110ad..b2b5b291c845 100644
--- a/dev-util/eric/Manifest
+++ b/dev-util/eric/Manifest
@@ -1,8 +1,8 @@
MD5 c10e31754a159c58fb336f5cf011b6e0 ChangeLog 666
MD5 9323682d5fa87404e01c5d59250d0ebf eric-3.1.ebuild 712
-MD5 a5fc63540ca3ab1baa859457a51345ba eric-3.2.ebuild 712
+MD5 4fbe6cad8ebf480bc834788a3e190b03 eric-3.2.ebuild 712
MD5 1d316caf986650a915b6df8a86ab001e metadata.xml 238
-MD5 29634ce6b9bd0c07cc16f9628fe462c6 eric-3.3.1.ebuild 1653
+MD5 00b4e172a1b74f001eb518ddb9970358 eric-3.3.1.ebuild 1751
MD5 f86966aea98b16417151e6f923c5d8a9 files/digest-eric-3.1 60
MD5 d76f40c69e1ba7c836d9344e03f27648 files/digest-eric-3.2 60
MD5 d952a231096b3ca5e91b51900332eb9a files/install.py.eric-3.3.1.diff 1185
diff --git a/dev-util/eric/eric-3.2.ebuild b/dev-util/eric/eric-3.2.ebuild
index 3512c74aa7dd..a52727c41a33 100644
--- a/dev-util/eric/eric-3.2.ebuild
+++ b/dev-util/eric/eric-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.2.ebuild,v 1.3 2004/01/11 21:31:15 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.2.ebuild,v 1.4 2004/01/18 01:43:40 pythonhead Exp $
IUSE=""
DESCRIPTION="The eric3 Python IDE"
@@ -17,7 +17,7 @@ DEPEND="virtual/glibc
>=dev-python/qscintilla-1.52
>=dev-lang/python-2.2.1
>=dev-python/sip-3.6
- <=dev-python/PyQt-3.8.1"
+ >=dev-python/PyQt-3.8.1"
src_install() {
python install.py \
diff --git a/dev-util/eric/eric-3.3.1.ebuild b/dev-util/eric/eric-3.3.1.ebuild
new file mode 100644
index 000000000000..825a9d0a7171
--- /dev/null
+++ b/dev-util/eric/eric-3.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-3.3.1.ebuild,v 1.1 2004/01/18 01:43:40 pythonhead Exp $
+
+IUSE="idl"
+
+inherit distutils eutils
+
+DESCRIPTION="eric3 is a full featured Python IDE that is written in PyQt using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/detlev/eric3.html"
+SRC_URI="http://www.die-offenbachs.de/detlev/files/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+distutils_python_version
+IDIR="/usr/lib/python${PYVER}/site-packages/eric3/"
+ADIR=${IDIR}"apis/"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.1
+ >=dev-python/qscintilla-1.53
+ >=dev-lang/python-2.2.1
+ >=dev-python/sip-3.8
+ >=dev-python/PyQt-3.8.1"
+
+RDEPEND="${RDEPEND}
+ idl? ( net-misc/omniORB )"
+
+src_compile() {
+ epatch ${FILESDIR}/install.py.${PF}.diff
+}
+
+src_install() {
+ cp ${S}/patch_modpython.py ${S}/eric/Tools
+ python install.py \
+ -b /usr/bin \
+ -i ${D}
+ dodoc HISTORY LICENSE.GPL THANKS eric/README*
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Execute the command \"ebuild /var/db/pkg/dev-util/${PF}/${PF}.ebuild config\""
+ einfo to generate the api files for the autocompletion/calltips feature of eric3.
+ einfo "The api files will be placed in \"${ADIR}\"."
+ einfo "You have to configure their usage in the eric3 Preferences Dialog -> Editor -> APIs."
+ einfo ""
+ einfo "If you want to use eric3 with Mod_python, have a look at"
+ einfo "\"${IDIR}Tools/patch_modpython.py\"."
+ einfo ""
+}
+
+pkg_config() {
+ mkdir ${ADIR}
+ einfo "Creating api files... (get a coffee)"
+ python ${IDIR}Tools/gen_python_api.py ${ADIR}
+ python ${IDIR}Tools/gen_pyqt_api.py /usr/share/sip ${ADIR}
+}
diff --git a/dev-util/eric/files/digest-eric-3.3.1 b/dev-util/eric/files/digest-eric-3.3.1
new file mode 100644
index 000000000000..741f1dfeaba0
--- /dev/null
+++ b/dev-util/eric/files/digest-eric-3.3.1
@@ -0,0 +1 @@
+MD5 b90eb45006bf66bedab872870557e08a eric-3.3.1.tar.gz 1270274
diff --git a/dev-util/eric/files/install.py.eric-3.3.1.diff b/dev-util/eric/files/install.py.eric-3.3.1.diff
new file mode 100644
index 000000000000..e09fb23db40d
--- /dev/null
+++ b/dev-util/eric/files/install.py.eric-3.3.1.diff
@@ -0,0 +1,36 @@
+--- install.py.eric-3.3.1 2003-12-12 23:31:57.000000000 +0100
++++ install.py 2003-12-12 23:33:45.000000000 +0100
+@@ -159,33 +159,6 @@
+ bindir = platBinDir
+ mdir = modDir
+
+- # Cleanup old stuff
+- # Remove the wrapper scripts
+- rem_ename = wrapperName(platBinDir,"eric3")
+- rem_uname = wrapperName(platBinDir,"eric3-unittest")
+- rem_hname = wrapperName(platBinDir,"eric3-helpviewer")
+- rem_dname = wrapperName(platBinDir,"eric3-doc")
+- rem_ouname = wrapperName(platBinDir,"qtunittest")
+- rem_ohname = wrapperName(platBinDir,"helpviewer")
+- if os.path.exists(rem_ename):
+- os.remove(rem_ename)
+- if os.path.exists(rem_uname):
+- os.remove(rem_uname)
+- if os.path.exists(rem_hname):
+- os.remove(rem_hname)
+- if os.path.exists(rem_dname):
+- os.remove(rem_dname)
+- if os.path.exists(rem_ouname):
+- os.remove(rem_ouname)
+- if os.path.exists(rem_ohname):
+- os.remove(rem_ohname)
+-
+- # Cleanup the install directory
+- try:
+- shutil.rmtree(ericdir, 1)
+- except:
+- pass
+-
+ # Install the files
+ # make the install directory tree
+ os.makedirs(ericpixdir)