summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-06-03 11:45:38 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-06-03 11:45:38 +0000
commit96edad46cbe7cab024b64165d4851a9785cf8b98 (patch)
tree4a90d8b3fac855fade944d4832129de87eb0402f /dev-util/eclipse-emf-bin
parentNew eclass for all eclipse extensions (diff)
downloadhistorical-96edad46cbe7cab024b64165d4851a9785cf8b98.tar.gz
historical-96edad46cbe7cab024b64165d4851a9785cf8b98.tar.bz2
historical-96edad46cbe7cab024b64165d4851a9785cf8b98.zip
Fixes #50003.
Diffstat (limited to 'dev-util/eclipse-emf-bin')
-rw-r--r--dev-util/eclipse-emf-bin/ChangeLog11
-rw-r--r--dev-util/eclipse-emf-bin/Manifest4
-rw-r--r--dev-util/eclipse-emf-bin/eclipse-emf-bin-200403250631.ebuild32
-rw-r--r--dev-util/eclipse-emf-bin/files/digest-eclipse-emf-bin-2004032506311
-rw-r--r--dev-util/eclipse-emf-bin/metadata.xml16
5 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/eclipse-emf-bin/ChangeLog b/dev-util/eclipse-emf-bin/ChangeLog
new file mode 100644
index 000000000000..2a5acb3c5763
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-util/eclipse-emf-bin
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-emf-bin/ChangeLog,v 1.1 2004/06/03 11:45:38 karltk Exp $
+
+*eclipse-emf-bin-200403250631 (01 Jun 2004)
+
+ 01 Jun 2004; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-emf-bin-200403250631.ebuild:
+ Initial import. Ebuild submitted by Kai Zimmermann <zimmermann79@gmx.de>, with
+ some modifications by myself to use the eclipse-ext eclass.
+
diff --git a/dev-util/eclipse-emf-bin/Manifest b/dev-util/eclipse-emf-bin/Manifest
new file mode 100644
index 000000000000..12aa433a4999
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/Manifest
@@ -0,0 +1,4 @@
+MD5 5455e00ff6d097fb896beefefd596614 eclipse-emf-bin-200403250631.ebuild 930
+MD5 5cf381d639ecdc836696f2b2ef6ad001 ChangeLog 514
+MD5 3752b9c7955e5e920a6271e8448ace90 metadata.xml 806
+MD5 6f8b332c301e2b5d3ed4a4ca3df35f87 files/digest-eclipse-emf-bin-200403250631 75
diff --git a/dev-util/eclipse-emf-bin/eclipse-emf-bin-200403250631.ebuild b/dev-util/eclipse-emf-bin/eclipse-emf-bin-200403250631.ebuild
new file mode 100644
index 000000000000..bb7568c9a198
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/eclipse-emf-bin-200403250631.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-emf-bin/eclipse-emf-bin-200403250631.ebuild,v 1.1 2004/06/03 11:45:38 karltk Exp $
+
+inherit eclipse-ext
+
+DESCRIPTION="EMF is a modeling framework and code generation facility for building tools and other applications based on a structured data model."
+HOMEPAGE="http://www.eclipse.org/emf/"
+SRC_URI="http://download.eclipse.org/tools/emf/downloads/drops/2.0/I200403250631/emf-runtime-I200403250631.zip"
+LICENSE="CPL-1.0"
+SLOT="2"
+KEYWORDS="~x86"
+DEPEND=">=dev-util/eclipse-sdk-3.0.0_pre8"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_compile() {
+ einfo "${P} is a binary package"
+}
+
+src_install () {
+ eclipse-ext_require-slot 3
+
+ eclipse-ext_create-ext-layout binary
+
+ eclipse-ext_install-features features/*
+ eclipse-ext_install-plugins plugins/*
+}
diff --git a/dev-util/eclipse-emf-bin/files/digest-eclipse-emf-bin-200403250631 b/dev-util/eclipse-emf-bin/files/digest-eclipse-emf-bin-200403250631
new file mode 100644
index 000000000000..0be71ebfece1
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/files/digest-eclipse-emf-bin-200403250631
@@ -0,0 +1 @@
+MD5 c8ad43bdb47207c257306213b63b8124 emf-runtime-I200403250631.zip 2131008
diff --git a/dev-util/eclipse-emf-bin/metadata.xml b/dev-util/eclipse-emf-bin/metadata.xml
new file mode 100644
index 000000000000..bb18246e304c
--- /dev/null
+++ b/dev-util/eclipse-emf-bin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+EMF is a modeling framework and code generation facility for building tools and
+other applications based on a structured data model. From a model specification
+described in XMI, EMF provides tools and runtime support to produce a set of
+Java classes for the model, a set of adapter classes that enable viewing and
+command-based editing of the model, and a basic editor. Models can be specified
+using annotated Java, XML documents, or modeling tools like Rational Rose, then
+imported into EMF. Most important of all, EMF provides the foundation for
+interoperability with other EMF-based tools and applications.
+</longdescription>
+</pkgmetadata>