summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2011-08-02 05:31:16 +0000
committerBrian Harring <ferringb@gentoo.org>2011-08-02 05:31:16 +0000
commit5fd13e1fe5695481b9b3b4f2eefaf84c22b6b1c0 (patch)
treef77cd59a96b3273bcb8ab905c37136ae2ae2f5e0 /dev-util/diffball/diffball-1.0.1.ebuild
parentStable for HPPA (bug #375579). (diff)
downloadhistorical-5fd13e1fe5695481b9b3b4f2eefaf84c22b6b1c0.tar.gz
historical-5fd13e1fe5695481b9b3b4f2eefaf84c22b6b1c0.tar.bz2
historical-5fd13e1fe5695481b9b3b4f2eefaf84c22b6b1c0.zip
bump diffball to 1.0.1 w/ xz support
Package-Manager: portage-2.1.10.6/cvs/Linux x86_64
Diffstat (limited to 'dev-util/diffball/diffball-1.0.1.ebuild')
-rw-r--r--dev-util/diffball/diffball-1.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/diffball/diffball-1.0.1.ebuild b/dev-util/diffball/diffball-1.0.1.ebuild
new file mode 100644
index 000000000000..fd1d80bde8b0
--- /dev/null
+++ b/dev-util/diffball/diffball-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffball/diffball-1.0.1.ebuild,v 1.1 2011/08/02 05:31:16 ferringb Exp $
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="http://diffball.googlecode.com/"
+SRC_URI="http://diffball.googlecode.com/files/${PN}-${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="debug"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+# Invalid RESTRICT for source package. Investigate.
+RESTRICT="strip"
+
+src_compile() {
+ econf $(use_enable debug asserts)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}