summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-29 00:51:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-29 00:51:19 +0000
commit2c42b3a153b7dea2036b374d7bb12e52521f8e37 (patch)
tree8f677356f8e5e074dbe80a9bf842fb1cf840a791 /dev-util/darcs
parentAdded ~sparc keyword. (diff)
downloadhistorical-2c42b3a153b7dea2036b374d7bb12e52521f8e37.tar.gz
historical-2c42b3a153b7dea2036b374d7bb12e52521f8e37.tar.bz2
historical-2c42b3a153b7dea2036b374d7bb12e52521f8e37.zip
move from net-ftp #45968
Diffstat (limited to 'dev-util/darcs')
-rw-r--r--dev-util/darcs/darcs-0.9.17.ebuild19
1 files changed, 6 insertions, 13 deletions
diff --git a/dev-util/darcs/darcs-0.9.17.ebuild b/dev-util/darcs/darcs-0.9.17.ebuild
index cad0499f2e85..6ecefc1fab47 100644
--- a/dev-util/darcs/darcs-0.9.17.ebuild
+++ b/dev-util/darcs/darcs-0.9.17.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-0.9.17.ebuild,v 1.2 2004/03/18 08:27:31 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-0.9.17.ebuild,v 1.3 2004/03/29 00:51:19 vapier Exp $
DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
HOMEPAGE="http://abridgegame.org/darcs"
SRC_URI="http://abridgegame.org/darcs/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="doc wxwindows"
-DEPEND=">=net-ftp/curl-7.10.2
+DEPEND=">=net-misc/curl-7.10.2
>=virtual/ghc-6.0
wxwindows? ( dev-haskell/wxhaskell )
doc? ( virtual/tetex
dev-tex/latex2html )"
-
-RDEPEND=">=net-ftp/curl-7.10.2"
-
-S=${WORKDIR}/${P}
+RDEPEND=">=net-misc/curl-7.10.2"
src_compile() {
local myconf
myconf="`use_with wxwindows wx`"
- if [ `use doc` ]; then
+ if use doc ; then
mv GNUmakefile GNUmakefile.orig
cat GNUmakefile.orig \
| sed "s:/doc:/doc/${PF}:" \
@@ -36,12 +34,7 @@ src_compile() {
| sed 's/^.*TARGETS.*\(darcs\.ps\|manual\).*$/:/' \
> configure
fi
- sh ./configure \
- --prefix=/usr \
- --datadir=/usr/share \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- ${myconf} || die
+ econf ${myconf} || die
echo 'INSTALLWHAT=installbin' >> autoconf.mk
make all || die
}