summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-12-30 02:12:13 +0000
committerMatthew Turk <satai@gentoo.org>2002-12-30 02:12:13 +0000
commitf9650829b82acb005d8d5fe6bcd77fd753bc1157 (patch)
tree8759b3a7efb0549a0af4615914c555cc15fec2f6 /dev-util/cweb/cweb-3.64.ebuild
parentNew package, Bug ID #12588, 12586 (diff)
downloadhistorical-f9650829b82acb005d8d5fe6bcd77fd753bc1157.tar.gz
historical-f9650829b82acb005d8d5fe6bcd77fd753bc1157.tar.bz2
historical-f9650829b82acb005d8d5fe6bcd77fd753bc1157.zip
Version bump, closes 11834.
Diffstat (limited to 'dev-util/cweb/cweb-3.64.ebuild')
-rw-r--r--dev-util/cweb/cweb-3.64.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cweb/cweb-3.64.ebuild b/dev-util/cweb/cweb-3.64.ebuild
new file mode 100644
index 000000000000..8b310f1c6707
--- /dev/null
+++ b/dev-util/cweb/cweb-3.64.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cweb/cweb-3.64.ebuild,v 1.1 2002/12/30 02:12:13 satai Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Knuth's and Levy's C/C++ documenting system"
+SRC_URI="ftp://labrea.stanford.edu/pub/cweb/cweb-${PV}.tar.gz"
+HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/cweb.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 sparc "
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ #emake won't work, because cweave needs ctangle to compile
+ make all CFLAGS="${CFLAGS}" LINKFLAGS="-s" || die
+}
+
+src_install () {
+ dobin ctangle cweave
+ doman cweb.1
+ dodoc README cwebman.tex
+ dodir /usr/share/texmf/tex/generic
+ insinto /usr/share/texmf/tex/generic
+ doins cwebmac.tex
+ dodir /usr/lib/cweb
+ insinto /usr/lib/cweb
+ doins c++lib.w
+ dodir /usr/share/emacs/site-lisp/
+ insinto /usr/share/emacs/site-lisp/
+ doins cweb.el
+}
+
+# Going to use this, just to make sure. May convert to a latex-package later.
+pkg_postinst() {
+ texconfig rehash
+}