summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2011-04-10 03:10:17 +0000
committerJonathan Callen <jcallen@gentoo.org>2011-04-10 03:10:17 +0000
commit335dcaed51a7f1ca312be8c7156d31f92c7654ab (patch)
tree8fc8258e7a2055ec9657b81e7a9701b12c9c4bcf /dev-util/cunit
parentFix compatibility with Python 3.2 (bug #351063). (diff)
downloadhistorical-335dcaed51a7f1ca312be8c7156d31f92c7654ab.tar.gz
historical-335dcaed51a7f1ca312be8c7156d31f92c7654ab.tar.bz2
historical-335dcaed51a7f1ca312be8c7156d31f92c7654ab.zip
Add prefix support, bump EAPI to 3, add prefix keywords
Package-Manager: portage-2.2.0_alpha29_p11/cvs/Linux i686
Diffstat (limited to 'dev-util/cunit')
-rw-r--r--dev-util/cunit/ChangeLog7
-rw-r--r--dev-util/cunit/cunit-2.1-r1.ebuild16
2 files changed, 12 insertions, 11 deletions
diff --git a/dev-util/cunit/ChangeLog b/dev-util/cunit/ChangeLog
index dc6d9d17ef41..9f320e7f70a4 100644
--- a/dev-util/cunit/ChangeLog
+++ b/dev-util/cunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cunit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.28 2009/09/23 17:42:09 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.29 2011/04/10 02:59:58 abcd Exp $
+
+ 10 Apr 2011; Jonathan Callen <abcd@gentoo.org> cunit-2.1-r1.ebuild:
+ Add prefix support, bump EAPI to 3, add prefix keywords
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> cunit-1.0.0.8.ebuild,
cunit-1.1.0.1-r1.ebuild, cunit-2.0.ebuild, cunit-2.1.ebuild,
diff --git a/dev-util/cunit/cunit-2.1-r1.ebuild b/dev-util/cunit/cunit-2.1-r1.ebuild
index 1dca1215914d..458cdc3d7af0 100644
--- a/dev-util/cunit/cunit-2.1-r1.ebuild
+++ b/dev-util/cunit/cunit-2.1-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1-r1.ebuild,v 1.6 2010/04/12 19:03:07 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1-r1.ebuild,v 1.7 2011/04/10 02:59:58 abcd Exp $
+EAPI=3
inherit eutils autotools
MY_PN='CUnit'
@@ -15,23 +16,20 @@ HOMEPAGE="http://cunit.sourceforge.net"
DEPEND=""
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -e "/^docdir/d" -i doc/Makefile.am
sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \
-i doc/headers/Makefile.am
eautoreconf
}
-src_compile() {
- econf --docdir=/usr/share/doc/${PF}
- emake || die "make failed"
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}
}
src_install() {