summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2008-09-27 16:15:44 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2008-09-27 16:15:44 +0000
commit7473081e1113deeb3f84fd7c52c4e32277d94e59 (patch)
treebfe63b5faec5f84060a993536c18573e28c5b57e /dev-util/cmake
parentarm stable wrt #197752 (diff)
downloadhistorical-7473081e1113deeb3f84fd7c52c4e32277d94e59.tar.gz
historical-7473081e1113deeb3f84fd7c52c4e32277d94e59.tar.bz2
historical-7473081e1113deeb3f84fd7c52c4e32277d94e59.zip
Version bump and removed old version.
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog9
-rw-r--r--dev-util/cmake/cmake-2.6.2.ebuild (renamed from dev-util/cmake/cmake-2.6.0.ebuild)34
2 files changed, 36 insertions, 7 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index a5ada928af2f..ebbdd93907dc 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.74 2008/09/01 22:22:00 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.75 2008/09/27 16:15:44 cryos Exp $
- 01 Sep 2008; Marcus D. Hanwell <cryos@gentoo.org> ChangeLog:
- Removed unused version.
+*cmake-2.6.2 (27 Sep 2008)
+
+ 27 Sep 2008; Marcus D. Hanwell <cryos@gentoo.org> -cmake-2.6.0.ebuild,
+ +cmake-2.6.2.ebuild:
+ Version bump and removed old version.
*cmake-2.6.1 (27 Aug 2008)
diff --git a/dev-util/cmake/cmake-2.6.0.ebuild b/dev-util/cmake/cmake-2.6.2.ebuild
index 657d2c2d2258..896798d7887e 100644
--- a/dev-util/cmake/cmake-2.6.0.ebuild
+++ b/dev-util/cmake/cmake-2.6.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.0.ebuild,v 1.1 2008/05/08 15:53:11 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.2.ebuild,v 1.1 2008/09/27 16:15:44 cryos Exp $
-inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
+EAPI="1"
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic
MY_PV="${PV/rc/RC-}"
MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
@@ -14,13 +16,16 @@ SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.
LICENSE="CMake"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs vim-syntax"
+IUSE="emacs qt4 vim-syntax"
DEPEND=">=net-misc/curl-7.16.4
>=dev-libs/expat-2.0.1
>=dev-libs/libxml2-2.6.28
>=dev-libs/xmlrpc-c-1.06.09
emacs? ( virtual/emacs )
+ qt4? ( || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4 )
+ >=x11-libs/qt-4.3:4 ) )
vim-syntax? ( || (
app-editors/vim
app-editors/gvim ) )"
@@ -29,6 +34,8 @@ RDEPEND="${DEPEND}"
SITEFILE="50${PN}-gentoo.el"
VIMFILE="${PN}.vim"
+S="${WORKDIR}/${MY_P}"
+
pkg_setup() {
if ! built_with_use -o dev-libs/xmlrpc-c curl libwww; then
echo
@@ -55,12 +62,31 @@ src_compile() {
tc-export CC CXX LD
+ local qt_arg
+ if use qt4; then
+ qt_arg="--qt-gui"
+ else
+ qt_arg="--no-qt-gui"
+ fi
+
+ local par_arg
+ echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
./bootstrap \
--system-libs \
--prefix=/usr \
--docdir=/share/doc/${PF} \
--datadir=/share/${PN} \
- --mandir=/share/man || die "./bootstrap failed"
+ --mandir=/share/man \
+ "$qt_arg" \
+ "$par_arg" || die "./bootstrap failed"
+
emake || die "emake failed."
if use emacs; then
elisp-compile Docs/cmake-mode.el || die "elisp compile failed"