summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2010-03-06 04:57:14 +0000
committerRyan Hill <rhill@gentoo.org>2010-03-06 04:57:14 +0000
commit31574556a40f3ccce2dee88185ef535f53e5f14f (patch)
tree8025193471ed8542e6fb75e928fc2501fceb24dc /dev-util/boa-constructor/boa-constructor-0.6.1.ebuild
parentUse SUPPORT_PYTHON_ABIS. Remove old. (diff)
downloadhistorical-31574556a40f3ccce2dee88185ef535f53e5f14f.tar.gz
historical-31574556a40f3ccce2dee88185ef535f53e5f14f.tar.bz2
historical-31574556a40f3ccce2dee88185ef535f53e5f14f.zip
Clean up python bits. EAPI 2. Don't byte-compile modules to prevent
SyntaxErrors. Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'dev-util/boa-constructor/boa-constructor-0.6.1.ebuild')
-rw-r--r--dev-util/boa-constructor/boa-constructor-0.6.1.ebuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild b/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild
index 8056c36bbfda..3c8ec72292b6 100644
--- a/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild
+++ b/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild,v 1.5 2008/10/18 16:45:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boa-constructor/boa-constructor-0.6.1.ebuild,v 1.6 2010/03/06 04:57:14 dirtyepic Exp $
+
+EAPI=2
inherit eutils python multilib
@@ -13,19 +15,18 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ppc ~sparc x86 ~x86-fbsd"
IUSE=""
-RDEPEND="=dev-python/wxpython-2.6*
+RDEPEND="dev-python/wxpython:2.6
dev-libs/expat"
DEPEND="${RDEPEND}
app-arch/unzip"
src_compile() {
- python -c "import compileall; compileall.compile_dir('.', force=1)"
+ "$(PYTHON)" -c "import compileall; compileall.compile_dir('.', force=1)"
}
src_install() {
- python_version
- local boadir="/usr/$(get_libdir)/python${PYVER}/site-packages/boa"
+ local boadir="$(python_get_sitedir)"/boa
local dir
for dir in $(find . -type d)
@@ -48,11 +49,3 @@ src_install() {
dodoc Bugs.txt Changes.txt Credits.txt README.txt
}
-
-pkg_postinst() {
- python_mod_optimize
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}