summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-03 18:53:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-03 18:53:02 +0000
commitd180d93de2b07012ded0e87c720594e03c71e35b (patch)
tree2e904d28ccafb7d01f75d717665589aeb58fa8ea /dev-tex
parentInitial import. Standalone pdftex patched to use poppler. (diff)
downloadhistorical-d180d93de2b07012ded0e87c720594e03c71e35b.tar.gz
historical-d180d93de2b07012ded0e87c720594e03c71e35b.tar.bz2
historical-d180d93de2b07012ded0e87c720594e03c71e35b.zip
Initial import. Standalone version of luatex patched to use poppler. Not very useful without TeX Live 2008 but that is a start.
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26.3 x86_64
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/luatex/ChangeLog11
-rw-r--r--dev-tex/luatex/luatex-0.29.0.ebuild132
-rw-r--r--dev-tex/luatex/metadata.xml10
3 files changed, 153 insertions, 0 deletions
diff --git a/dev-tex/luatex/ChangeLog b/dev-tex/luatex/ChangeLog
new file mode 100644
index 000000000000..dffac3c50bff
--- /dev/null
+++ b/dev-tex/luatex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-tex/luatex
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/ChangeLog,v 1.1 2008/09/03 18:53:02 aballier Exp $
+
+*luatex-0.29.0 (03 Sep 2008)
+
+ 03 Sep 2008; Alexis Ballier <aballier@gentoo.org> +metadata.xml,
+ +luatex-0.29.0.ebuild:
+ Initial import. Standalone version of luatex patched to use poppler. Not
+ very useful without TeX Live 2008 but that is a start.
+
diff --git a/dev-tex/luatex/luatex-0.29.0.ebuild b/dev-tex/luatex/luatex-0.29.0.ebuild
new file mode 100644
index 000000000000..1f4aa163e0a1
--- /dev/null
+++ b/dev-tex/luatex/luatex-0.29.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/luatex/luatex-0.29.0.ebuild,v 1.1 2008/09/03 18:53:02 aballier Exp $
+
+inherit libtool multilib eutils toolchain-funcs
+
+PATCHLEVEL="1"
+
+DESCRIPTION="An extended version of pdfTeX using Lua as an embedded scripting language."
+HOMEPAGE="http://www.luatex.org/"
+SRC_URI="http://foundry.supelec.fr/frs/download.php/664/${PN}-beta-${PV}.tar.bz2
+ mirror://gentoo/${PN}-patches-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="dev-tex/mplib
+ dev-libs/zziplib
+ media-libs/libpng
+ app-text/poppler
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${PN}-beta-${PV}/src"
+
+pkg_setup() {
+ if ! built_with_use dev-tex/mplib lua ; then
+ eerror "You need to build dev-tex/mplib with the lua useflag"
+ eerror "${PN} requires mplib's lua bindings."
+ die "Please install dev-tex/mplib with the lua useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ elibtoolize
+}
+
+src_compile() {
+ tc-export CC CXX AR RANLIB
+ export NATIVE='.'
+ mkdir -p "${WORKDIR}/${PN}-beta-${PV}/build"
+ cd "${WORKDIR}/${PN}-beta-${PV}/build"
+ ECONF_SOURCE="${S}" econf \
+ --without-cxx-runtime-hack \
+ --without-aleph \
+ --without-bibtex8 \
+ --without-cjkutils \
+ --without-detex \
+ --without-dialog \
+ --without-dtl \
+ --without-dvi2tty \
+ --without-dvidvi \
+ --without-dviljk \
+ --without-dvipdfm \
+ --without-dvipdfmx \
+ --without-dvipng \
+ --without-dvipos \
+ --without-dvipsk \
+ --without-etex \
+ --without-gsftopk \
+ --without-lacheck \
+ --without-lcdf-typetools \
+ --without-makeindexk \
+ --without-mkocp-default \
+ --without-mkofm-default \
+ --without-musixflx \
+ --without-omega \
+ --without-pdfopen \
+ --without-ps2eps \
+ --without-ps2pkm \
+ --without-psutils \
+ --without-sam2p \
+ --without-seetexk \
+ --without-t1utils \
+ --without-tetex \
+ --without-tex4htk \
+ --without-texi2html \
+ --without-texinfo \
+ --without-texlive \
+ --without-ttf2pk \
+ --without-tth \
+ --without-xdv2pdf \
+ --without-xdvik \
+ --without-xdvipdfmx \
+ --without-xetex \
+ --disable-largefile \
+ --with-system-zlib \
+ --with-system-pnglib
+
+ cd "${WORKDIR}/${PN}-beta-${PV}/build/texk/web2c"
+ emake \
+ LIBMPLIBDEP="/usr/$(get_libdir)/libmplib/mplib.la" \
+ LDZZIPLIB="$(pkg-config --libs zziplib)" ZZIPLIBINC="$(pkg-config --cflags zziplib)" \
+ LIBXPDFDEP="" LDLIBXPDF="$(pkg-config --libs poppler)" \
+ LIBXPDFINCLUDE="$(pkg-config --cflags poppler)" LIBXPDFCPPFLAGS="$(pkg-config --cflags poppler)" \
+ LIBPNGINCLUDES="$(pkg-config --cflags libpng)" \
+ ZLIBSRCDIR="." \
+ luatex || die "failed to build luatex"
+}
+
+src_install() {
+ cd "${WORKDIR}/${PN}-beta-${PV}/build/texk/web2c"
+ emake bindir="${D}/usr/bin" \
+ LIBMPLIBDEP="/usr/$(get_libdir)/libmplib/mplib.la" \
+ LDZZIPLIB="$(pkg-config --libs zziplib)" ZZIPLIBINC="$(pkg-config --cflags zziplib)" \
+ LIBXPDFDEP="" LDLIBXPDF="$(pkg-config --libs poppler)" \
+ LIBXPDFINCLUDE="$(pkg-config --cflags poppler)" LIBXPDFCPPFLAGS="$(pkg-config --cflags poppler)" \
+ LIBPNGINCLUDES="$(pkg-config --cflags libpng)" \
+ ZLIBSRCDIR="." \
+ install-luatex || die "install-luatex failed"
+
+ dodoc "${WORKDIR}/${PN}-beta-${PV}/README"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins "${WORKDIR}/${PN}-beta-${PV}/manual/"*.pdf
+ fi
+}
+
+pkg_postinst() {
+ if ! has_version '>=dev-texlive/texlive-basic-2008' ; then
+ elog "Please note that this package does not install much files, mainly the"
+ elog "${PN} executable that will need other files in order to be useful.."
+ elog "Please consider installing a recent TeX distribution"
+ elog "like TeX Live 2008 to get the full power of ${PN}"
+ fi
+}
diff --git a/dev-tex/luatex/metadata.xml b/dev-tex/luatex/metadata.xml
new file mode 100644
index 000000000000..1d2fc95bdaa1
--- /dev/null
+++ b/dev-tex/luatex/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<longdescription lang="en">
+An experimental pdfTeX extension that is to eventually
+become its successor. It is developed by a subset of the
+current pdfTeX team.
+</longdescription>
+</pkgmetadata>