summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-11 14:02:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-11 14:02:04 +0000
commitd66a1c7863002a1f109272f6a1a4c8c090fde3f7 (patch)
tree52b86fa9e8d35e757f8ad77ce19cd206e9bab281 /dev-tex/mh/mh-20111011.ebuild
parentShutup compile phase informing us that there is nothing to do. (diff)
downloadhistorical-d66a1c7863002a1f109272f6a1a4c8c090fde3f7.tar.gz
historical-d66a1c7863002a1f109272f6a1a4c8c090fde3f7.tar.bz2
historical-d66a1c7863002a1f109272f6a1a4c8c090fde3f7.zip
version bump, bug #378477
Package-Manager: portage-2.2.0_alpha66/cvs/Linux x86_64
Diffstat (limited to 'dev-tex/mh/mh-20111011.ebuild')
-rw-r--r--dev-tex/mh/mh-20111011.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-tex/mh/mh-20111011.ebuild b/dev-tex/mh/mh-20111011.ebuild
new file mode 100644
index 000000000000..8f5f4cf8e6e9
--- /dev/null
+++ b/dev-tex/mh/mh-20111011.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/mh-20111011.ebuild,v 1.1 2011/10/11 14:02:04 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="Additional LaTeX math tools."
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/mh/"
+SRC_URI="mirror://gentoo/${P}.zip"
+LICENSE="LPPL-1.3"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-tex/xcolor
+ || ( >=dev-texlive/texlive-latexrecommended-2011 >=dev-texlive/texlive-latex3-2008 )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ # To avoid sandbox violations
+ export VARTEXFONTS="${T}/fonts"
+
+ # Unpacking *.dtx
+ for i in *.dtx; do
+ tex ${i} || die "TeXing ${i} failed"
+ done
+
+ latex-package_src_compile
+}
+
+src_install() {
+ latex-package_src_doinstall styles fonts bin
+
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.sym
+
+ use doc && latex-package_src_doinstall doc
+ dodoc README
+}