summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2014-07-15 20:11:24 +0000
committerDenis Dupeyron <calchan@gentoo.org>2014-07-15 20:11:24 +0000
commiteb7a0568592eed09bd74d619dd733777b958502e (patch)
treef148194f0cfcb4c9d69b420e6f7da5ef03e8a388 /dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild
parentAdd perl-5.16, 18, 20 version; improve dependencies; remove old (diff)
downloadhistorical-eb7a0568592eed09bd74d619dd733777b958502e.tar.gz
historical-eb7a0568592eed09bd74d619dd733777b958502e.tar.bz2
historical-eb7a0568592eed09bd74d619dd733777b958502e.zip
Version bump.
Package-Manager: portage-2.2.10/cvs/Linux x86_64
Diffstat (limited to 'dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild')
-rw-r--r--dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild b/dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild
new file mode 100644
index 000000000000..8f22b86395c5
--- /dev/null
+++ b/dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/circuit_macros-7.9.2.ebuild,v 1.1 2014/07/15 20:11:23 calchan Exp $
+
+EAPI=5
+
+inherit texlive-common
+
+DESCRIPTION="M4 Macros for Electric circuit diagrams in TeX or LaTeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/"
+SRC_URI="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/Circuit_macros.tar.gz -> circuit_macros-${PV}.tar.gz"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +script"
+
+DEPEND=""
+RDEPEND="|| ( app-text/texlive[graphics] app-text/texlive[pstricks] )
+ media-gfx/dpic
+ sys-devel/m4
+ script? ( app-text/texlive[graphics]
+ dev-texlive/texlive-latexextra )"
+
+S="${WORKDIR}/Circuit_macros${PV}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins *.m4
+ insinto /usr/share/texmf-site/tex/latex/${PN}
+ doins boxdims.sty
+ dodoc README CHANGES Makefile doc/CMman.pdf
+ rm -f doc/CMman.pdf
+ use doc && dodoc -r doc
+ use examples && dodoc -r examples
+ use script && dobin "${FILESDIR}/cm2pdf"
+ docompress -x \
+ /usr/share/doc/${PF}/Makefile \
+ /usr/share/doc/${PF}/doc \
+ /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ etexmf-update
+ use script && einfo "cm2pdf was installed to automatically create PDFs. Run cm2pdf --help for usage help."
+}
+
+pkg_postrm() {
+ etexmf-update
+}