summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-26 04:02:53 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-26 04:02:53 +0000
commit57ad0f2f5361a1379d95ac4c56eae799256f4ed9 (patch)
tree13bafe20bbe05d752eb1de3674affd11132cc72f /dev-tcltk/expect/expect-5.37.1-r2.ebuild
parentthanks Az :) (diff)
downloadhistorical-57ad0f2f5361a1379d95ac4c56eae799256f4ed9.tar.gz
historical-57ad0f2f5361a1379d95ac4c56eae799256f4ed9.tar.bz2
historical-57ad0f2f5361a1379d95ac4c56eae799256f4ed9.zip
added optional installation of examples (if 'doc' is defined)
Diffstat (limited to 'dev-tcltk/expect/expect-5.37.1-r2.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.37.1-r2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-tcltk/expect/expect-5.37.1-r2.ebuild b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
new file mode 100644
index 000000000000..f1a400498f7b
--- /dev/null
+++ b/dev-tcltk/expect/expect-5.37.1-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.37.1-r2.ebuild,v 1.1 2002/10/26 04:02:49 george Exp $
+
+IUSE="X doc"
+
+#remove the trailing ".0" from the tarball version
+S=${WORKDIR}/${P%.1}
+
+DESCRIPTION="Expect is a tool for automating interactive applications"
+SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
+HOMEPAGE="http://expect.nist.gov/"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+LICENSE="BSD"
+
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
+
+
+src_compile() {
+
+ local myconf
+ local tclv
+ local tkv
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ #tkv isn't really needed, included for symmetry and the future
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+
+ #configure needs to find the files tclConfig.sh and tclInt.h
+ myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl$tclv/include/generic"
+
+ if use X; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/lib"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
+
+ econf $myconf --enable-shared || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+ #docs
+ dodoc Changelog FAQ HISTORY NEWS README
+
+ #install examples if 'doc' is set
+ if use doc; then
+ dodir /usr/share/doc/${PF}/examples/
+ cp example/* /usr/share/doc/${PF}/examples/
+ fi
+}
+