summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-04-17 12:37:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-04-17 12:37:41 +0000
commit8581e18ddde0d8d31c4d576b9294bdcd296a1595 (patch)
tree0cb0794485cf3b25ec76f6681992f8c03150bdfa /dev-ruby
parentVersion bump dev-haskell/xhtml-3000.2.0.1 (diff)
downloadhistorical-8581e18ddde0d8d31c4d576b9294bdcd296a1595.tar.gz
historical-8581e18ddde0d8d31c4d576b9294bdcd296a1595.tar.bz2
historical-8581e18ddde0d8d31c4d576b9294bdcd296a1595.zip
Initial import of mislav-will_paginate (new name of will_paginate). Loosely based on Wim Muskee work on bug #256077. Uses the github-produced tarball (renamed), has proper dependencies and an src_test function and installs a fake gemspec file.
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mislav-will_paginate/ChangeLog13
-rw-r--r--dev-ruby/mislav-will_paginate/Manifest14
-rw-r--r--dev-ruby/mislav-will_paginate/metadata.xml5
-rw-r--r--dev-ruby/mislav-will_paginate/mislav-will_paginate-2.3.7.ebuild69
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-ruby/mislav-will_paginate/ChangeLog b/dev-ruby/mislav-will_paginate/ChangeLog
new file mode 100644
index 000000000000..7bc52a854505
--- /dev/null
+++ b/dev-ruby/mislav-will_paginate/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-ruby/mislav-will_paginate
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mislav-will_paginate/ChangeLog,v 1.1 2009/04/17 12:37:41 flameeyes Exp $
+
+*mislav-will_paginate-2.3.7 (17 Apr 2009)
+
+ 17 Apr 2009; Diego E. Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +mislav-will_paginate-2.3.7.ebuild:
+ Initial import of mislav-will_paginate (new name of will_paginate).
+ Loosely based on Wim Muskee work on bug #256077. Uses the github-produced
+ tarball (renamed), has proper dependencies and an src_test function and
+ installs a fake gemspec file.
+
diff --git a/dev-ruby/mislav-will_paginate/Manifest b/dev-ruby/mislav-will_paginate/Manifest
new file mode 100644
index 000000000000..7190173ae2ec
--- /dev/null
+++ b/dev-ruby/mislav-will_paginate/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST mislav-will_paginate-2.3.7.tgz 36195 RMD160 6484e6e0cc0b60412ea4ca0eb100d4cf458c3435 SHA1 8f196b82316695addf1cee163a07ec2677152797 SHA256 933d8bce8bf33a424e67527ab2f8de55d7ea41d31116d57e827608763af1e59e
+EBUILD mislav-will_paginate-2.3.7.ebuild 1539 RMD160 dcf1dab5cc9079da9c518f960da08a306132fca7 SHA1 4ce6b7ea2548c0bd654e95bc69efef890659e971 SHA256 e289b470d62b019cc5940c31a2a1526504e094d6e216db97814ab6cb4192e4d0
+MISC ChangeLog 639 RMD160 5993c8270501c685f760039f77aa48ac363505e8 SHA1 c6e0d6b5c11f72e0fa9145c3d9cd68a6b7cd7cbe SHA256 708a632de315e1f48eee00015bee6385af79f663098c0d1ca1ae0b5df074abfc
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAknoeBsACgkQAiZjviIA2XismgCeLbGp57Ik2m2IL0I0jVZz3El4
+Xz8AnRV6fPMhHpovsPnNERU5+hE2nlGb
+=OYYe
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/mislav-will_paginate/metadata.xml b/dev-ruby/mislav-will_paginate/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/mislav-will_paginate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/mislav-will_paginate/mislav-will_paginate-2.3.7.ebuild b/dev-ruby/mislav-will_paginate/mislav-will_paginate-2.3.7.ebuild
new file mode 100644
index 000000000000..57638098c201
--- /dev/null
+++ b/dev-ruby/mislav-will_paginate/mislav-will_paginate-2.3.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mislav-will_paginate/mislav-will_paginate-2.3.7.ebuild,v 1.1 2009/04/17 12:37:41 flameeyes Exp $
+
+EAPI=2
+
+inherit ruby
+
+DESCRIPTION="Most awesome pagination solution for Ruby "
+HOMEPAGE="http://github.com/mislav/will_paginate/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+SRC_URI="http://github.com/mislav/will_paginate/tarball/v${PV} -> ${P}.tgz"
+
+USE_RUBY="ruby18"
+
+DEPEND="doc? ( dev-ruby/rake )
+ test? ( dev-ruby/rake )"
+RDEPEND=">=dev-ruby/activesupport-1.4.4"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cd "${WORKDIR}"/${PN}-*
+
+ sed -i -e "/s\.name/s:will_paginate:${PN}:" will_paginate.gemspec || die "unable to fix gemspec"
+}
+
+src_compile() {
+ cd "${WORKDIR}"/${PN}-*
+
+ if use doc; then
+ rake rdoc || die "rake rdoc failed"
+ fi
+}
+
+src_test() {
+ cd "${WORKDIR}"/${PN}-*
+
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${WORKDIR}"/${PN}-*
+
+ pushd lib
+ doruby -r * || die "install lib failed"
+ popd
+
+ insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')/../gems/1.8/specifications
+ newins will_paginate.gemspec ${P}.gemspec || die "Unable to install fake gemspec"
+
+ dodoc CHANGELOG.rdoc README.rdoc || die "Installing docs failed."
+
+ if use doc; then
+ pushd doc
+ dohtml -r * || die "Installing html documentation failed."
+ popd
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "Installing examples failes."
+ fi
+}