summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-10-20 13:10:54 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-10-20 13:10:54 +0000
commit7bac378aa46e17769881bc1c26768aa0797c215e (patch)
tree6e3f157a2df274f0329e225fc18b0804b9e060b4 /dev-ruby
parentVersion bump. (diff)
downloadhistorical-7bac378aa46e17769881bc1c26768aa0797c215e.tar.gz
historical-7bac378aa46e17769881bc1c26768aa0797c215e.tar.bz2
historical-7bac378aa46e17769881bc1c26768aa0797c215e.zip
Commit a slightly modified patch from -r1 from bug #107663
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog9
-rw-r--r--dev-ruby/activesupport/Manifest15
-rw-r--r--dev-ruby/activesupport/activesupport-1.1.1-r2.ebuild26
-rw-r--r--dev-ruby/activesupport/files/clean_logger-format_message-fix.patch16
-rw-r--r--dev-ruby/activesupport/files/digest-activesupport-1.1.1-r21
5 files changed, 60 insertions, 7 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 0e8819adf809..1a72fb5f86ba 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.15 2005/10/20 00:19:06 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.16 2005/10/20 13:10:54 caleb Exp $
+
+*activesupport-1.1.1-r2 (20 Oct 2005)
+
+ 20 Oct 2005; Caleb Tennis <caleb@gentoo.org>
+ +files/clean_logger-format_message-fix.patch,
+ +activesupport-1.1.1-r2.ebuild:
+ This is a slightly modified patch from -r1 from bug #107663
20 Oct 2005; Luca Barbato <lu_zero@gentoo.org>
activesupport-1.1.1-r1.ebuild:
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 51ccf46ade9a..7030eea03611 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,9 +1,12 @@
-MD5 3eec9f3fe48b51f49dbc1f171a3b026f metadata.xml 157
-MD5 2b25e77835ce5116302fdb17faa4d45f activesupport-1.2.1.ebuild 709
-MD5 9c01907ba62cf747089ec158a3aa1e7d activesupport-1.1.1.ebuild 721
+MD5 594e0ee28e692fc8a9513528b674a97b ChangeLog 2424
MD5 a30ffa5c8b09a079bbcc64dc9af8c647 activesupport-1.1.1-r1.ebuild 849
-MD5 f7361f6e626fd891865f97878bf584eb ChangeLog 2195
-MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1-r1 67
+MD5 313fb53e63711094394e399772d934bb activesupport-1.1.1-r2.ebuild 854
+MD5 9c01907ba62cf747089ec158a3aa1e7d activesupport-1.1.1.ebuild 721
+MD5 2b25e77835ce5116302fdb17faa4d45f activesupport-1.2.1.ebuild 709
MD5 98c856c2201ed8c0cc866e76dafd967f files/as_clean_logger_rb-fixed.patch 461
-MD5 19acdfd1ee8d7d1ccc47e9267eb87861 files/digest-activesupport-1.2.1 67
+MD5 b4579facfc245861ee22d45b15473db1 files/clean_logger-format_message-fix.patch 536
MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1 67
+MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1-r1 67
+MD5 3cc7197f8083599bef3678502c6b11a8 files/digest-activesupport-1.1.1-r2 67
+MD5 19acdfd1ee8d7d1ccc47e9267eb87861 files/digest-activesupport-1.2.1 67
+MD5 3eec9f3fe48b51f49dbc1f171a3b026f metadata.xml 157
diff --git a/dev-ruby/activesupport/activesupport-1.1.1-r2.ebuild b/dev-ruby/activesupport/activesupport-1.1.1-r2.ebuild
new file mode 100644
index 000000000000..968acf03ff97
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-1.1.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-1.1.1-r2.ebuild,v 1.1 2005/10/20 13:10:54 caleb Exp $
+
+inherit ruby gems eutils
+
+USE_RUBY="ruby18"
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/5160/${P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.2
+ >=dev-ruby/rubygems-0.8.10"
+
+src_install() {
+ gems_src_install
+ cd ${D}/${GEMSDIR}/gems
+ patch -p0 < ${FILESDIR}/clean_logger-format_message-fix.patch
+}
diff --git a/dev-ruby/activesupport/files/clean_logger-format_message-fix.patch b/dev-ruby/activesupport/files/clean_logger-format_message-fix.patch
new file mode 100644
index 000000000000..0c8bfdf939d4
--- /dev/null
+++ b/dev-ruby/activesupport/files/clean_logger-format_message-fix.patch
@@ -0,0 +1,16 @@
+--- activesupport-1.1.1/lib/active_support/clean_logger.rb.orig 2005-10-19 18:18:09.000000000 -0400
++++ activesupport-1.1.1/lib/active_support/clean_logger.rb 2005-10-19 18:07:00.000000000 -0400
+@@ -10,9 +10,11 @@
+ end
+
+ private
+- remove_const "Format"
++ if const_defined?(:Format) # Not defined in Ruby 1.8.3
++ remove_const "Format"
++ end
+ Format = "%s\n"
+- def format_message(severity, timestamp, msg, progname)
++ def format_message(severity, timestamp, progname, msg)
+ Format % [msg]
+ end
+ end
diff --git a/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r2 b/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r2
new file mode 100644
index 000000000000..bb6a24882e63
--- /dev/null
+++ b/dev-ruby/activesupport/files/digest-activesupport-1.1.1-r2
@@ -0,0 +1 @@
+MD5 091d2d98f3bf2bda1de0ad9f4368b28e activesupport-1.1.1.gem 26624