summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-18 14:10:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-18 14:10:09 +0000
commit11d898ad49e7df516f4f26c133b80263dec8f1f3 (patch)
tree6577fd80e74f6272e26438e21413c562cd8c8711 /dev-ruby/xpath
parentdrop one more useless die, since the ebuilds are eapi4 and emake dies on its own (diff)
downloadhistorical-11d898ad49e7df516f4f26c133b80263dec8f1f3.tar.gz
historical-11d898ad49e7df516f4f26c133b80263dec8f1f3.tar.bz2
historical-11d898ad49e7df516f4f26c133b80263dec8f1f3.zip
Initial import. Dependency of forthcoming capybara.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/ChangeLog10
-rw-r--r--dev-ruby/xpath/Manifest14
-rw-r--r--dev-ruby/xpath/metadata.xml5
-rw-r--r--dev-ruby/xpath/xpath-0.1.4.ebuild31
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/xpath/ChangeLog b/dev-ruby/xpath/ChangeLog
new file mode 100644
index 000000000000..aa9e544f68e9
--- /dev/null
+++ b/dev-ruby/xpath/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/xpath
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.1 2011/05/18 14:10:09 graaff Exp $
+
+*xpath-0.1.4 (18 May 2011)
+
+ 18 May 2011; Hans de Graaff <graaff@gentoo.org> +xpath-0.1.4.ebuild,
+ +metadata.xml:
+ Initial import. Dependency of forthcoming capybara.
+
diff --git a/dev-ruby/xpath/Manifest b/dev-ruby/xpath/Manifest
new file mode 100644
index 000000000000..5dc7b8b15d25
--- /dev/null
+++ b/dev-ruby/xpath/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST xpath-0.1.4.gem 13824 RMD160 cc49f5754044591a54e0572faf19031c5a13eb54 SHA1 d018d1940356a922d64bce2622505ef72894a275 SHA256 60a1363643edb3b3802fa1d7c5a042fed0f8f5f5589ed308a47f099ef5dcbf6f
+EBUILD xpath-0.1.4.ebuild 726 RMD160 82a4a0470b1410a47ac18ee6899c822dfd044595 SHA1 20173756d0e60e105078222a456631c88f941794 SHA256 f6acd9ca8b53a1d6a05417f6a76b98134310284d618f5d38a954e63d034e6994
+MISC ChangeLog 372 RMD160 4bf7bb16ebdc2bc923b0db91b2af18b8309a6631 SHA1 ce76940dd1d441d061a3d192ba60a2a3f5cc55b7 SHA256 7a23c0ff66405a7e58195c0e9f2187ce1270af9d487294bc25a4fd1d4e429356
+MISC metadata.xml 157 RMD160 5d9e2c7ecba96ffebd936d38acedf859cdea84e1 SHA1 8ce15dcc608eeb5616aeec610dc695cbe6f93e02 SHA256 11fba03a217e2d996f5cd8895493a5692ece8ddac2c1a2dfc71d0e830555121c
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk3T00wACgkQrnu0mw69JkptuwD+K1HYR2ZWeMHv/i2FYLfClhxp
+dKt7RcpDMe0v5GgLDiIA/ibICeDdrWelPxJYiYmMvDTdbIfhOvDeOX4VjtWrVx1D
+=3y8o
+-----END PGP SIGNATURE-----
diff --git a/dev-ruby/xpath/metadata.xml b/dev-ruby/xpath/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/xpath/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/xpath/xpath-0.1.4.ebuild b/dev-ruby/xpath/xpath-0.1.4.ebuild
new file mode 100644
index 000000000000..ca1b7b2107f2
--- /dev/null
+++ b/dev-ruby/xpath/xpath-0.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/xpath-0.1.4.ebuild,v 1.1 2011/05/18 14:10:09 graaff Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0."
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rspec spec || die "Tests failed."
+}