summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-10 16:00:55 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-10 16:00:55 +0000
commitc290d51757db95521585c7d60a95757a4efd8841 (patch)
tree0a6dc77bba08944614eac0e8da369cddae707d26 /dev-ruby/ruby-termios
parentInitial Import. Closes #47134 (diff)
downloadhistorical-c290d51757db95521585c7d60a95757a4efd8841.tar.gz
historical-c290d51757db95521585c7d60a95757a4efd8841.tar.bz2
historical-c290d51757db95521585c7d60a95757a4efd8841.zip
virtual/ruby fix
Diffstat (limited to 'dev-ruby/ruby-termios')
-rw-r--r--dev-ruby/ruby-termios/ChangeLog7
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild11
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-ruby/ruby-termios/ChangeLog b/dev-ruby/ruby-termios/ChangeLog
index cfad5fa50f6b..daa0a48ddc79 100644
--- a/dev-ruby/ruby-termios/ChangeLog
+++ b/dev-ruby/ruby-termios/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/ruby-termios
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ChangeLog,v 1.2 2003/05/30 22:26:00 twp Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ChangeLog,v 1.3 2004/04/10 15:58:59 usata Exp $
+
+ 11 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> ruby-termios-0.9.4.ebuild:
+ virtual/ruby fix
30 May 2003; Tom Payne <twp@gentoo.org> ruby-termios-0.9.4.ebuild :
Fixed LICENSE.
diff --git a/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
index 5e93f31bbff0..0e6ea4a178d1 100644
--- a/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
+++ b/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild
@@ -1,14 +1,17 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild,v 1.4 2004/02/22 22:26:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.4.ebuild,v 1.5 2004/04/10 15:58:59 usata Exp $
+
+inherit ruby
DESCRIPTION="A Ruby interface to termios"
-HOMEPAGE="http://arika.org/ruby/termios/"
+HOMEPAGE="http://arika.org/ruby/termios" # trailing / isn't needed
SRC_URI="http://arika.org/archive/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="~alpha ~hppa ~mips ~sparc x86"
-DEPEND=">=dev-lang/ruby-1.6"
+USE_RUBY="ruby16 ruby18 ruby19"
+DEPEND="virtual/ruby"
src_compile() {
ruby extconf.rb || die