summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 09:06:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 09:06:04 +0000
commit9c470564e378eff063319b7272b9b14ae209f2e9 (patch)
tree04f923a3b0b8348d5ec74bb0754c67e11e0f3010 /dev-ruby/httparty
parentclean up (diff)
downloadhistorical-9c470564e378eff063319b7272b9b14ae209f2e9.tar.gz
historical-9c470564e378eff063319b7272b9b14ae209f2e9.tar.bz2
historical-9c470564e378eff063319b7272b9b14ae209f2e9.zip
Version bump.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/ChangeLog8
-rw-r--r--dev-ruby/httparty/httparty-0.5.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index 76c5ab6a99d8..f8c86fe2d1ab 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.11 2010/01/31 11:33:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.12 2010/02/01 09:06:04 flameeyes Exp $
+
+*httparty-0.5.2 (01 Feb 2010)
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +httparty-0.5.2.ebuild:
+ Version bump.
*httparty-0.5.1 (31 Jan 2010)
diff --git a/dev-ruby/httparty/httparty-0.5.2.ebuild b/dev-ruby/httparty/httparty-0.5.2.ebuild
new file mode 100644
index 000000000000..0d78b31b6bcb
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.5.2.ebuild,v 1.1 2010/02/01 09:06:04 flameeyes Exp $
+
+EAPI=2
+
+# ruby19 → testsuite fails (might be crack's bug)
+# jruby → testsuite fails (seems like a testuite bug)
+USE_RUBY="ruby18"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
+HOMEPAGE="http://httparty.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Code should most likely be patched, but for now…
+ruby_add_rdepend '~dev-ruby/crack-0.1.6'
+
+ruby_add_bdepend 'dev-ruby/rspec dev-ruby/fakeweb'
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend 'ruby_targets_ruby18 test' 'dev-util/cucumber dev-ruby/activesupport:2.3'
+
+all_ruby_prepare() {
+ # as often, Rakefile depends on Jeweler's presence
+ sed -i \
+ -e '/check_dependencies/s:^:#:' \
+ Rakefile || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby18)
+ # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
+ ${RUBY} -S rake spec features || die "cucumber tests failed"
+ ;;
+ *)
+ ${RUBY} -S rake spec || die "cucumber tests failed"
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}