summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2001-08-03 16:17:18 +0000
committerDamon Conway <kabau@gentoo.org>2001-08-03 16:17:18 +0000
commitfacc59cee97d86f404c2100c68892288b2df99fc (patch)
tree9ee38510b70b250636084b641cf7b14e4d53b193 /dev-python
parentadded new netscape browser relesae. (diff)
downloadhistorical-facc59cee97d86f404c2100c68892288b2df99fc.tar.gz
historical-facc59cee97d86f404c2100c68892288b2df99fc.tar.bz2
historical-facc59cee97d86f404c2100c68892288b2df99fc.zip
Commiting initial revision of PyXML and pychecker. PyXML is a collection
of xml libraries for python. Pychecker looks for common bugs in python code.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyXML/files/digest-PyXML-0.6.51
-rw-r--r--dev-python/pychecker/files/digest-pychecker-0.7.51
-rw-r--r--dev-python/pychecker/pychecker-0.7.5.ebuild24
3 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/PyXML/files/digest-PyXML-0.6.5 b/dev-python/PyXML/files/digest-PyXML-0.6.5
new file mode 100644
index 000000000000..60826be54a4a
--- /dev/null
+++ b/dev-python/PyXML/files/digest-PyXML-0.6.5
@@ -0,0 +1 @@
+MD5 366c2405b1427f7997b2bd25a00ecbfe PyXML-0.6.5.tar.gz
diff --git a/dev-python/pychecker/files/digest-pychecker-0.7.5 b/dev-python/pychecker/files/digest-pychecker-0.7.5
new file mode 100644
index 000000000000..4d6fb01ef004
--- /dev/null
+++ b/dev-python/pychecker/files/digest-pychecker-0.7.5
@@ -0,0 +1 @@
+MD5 a810aac04be8a6f95d9b62b6df57c3de pychecker-0.7.5.tar.gz
diff --git a/dev-python/pychecker/pychecker-0.7.5.ebuild b/dev-python/pychecker/pychecker-0.7.5.ebuild
new file mode 100644
index 000000000000..6755b0b327b4
--- /dev/null
+++ b/dev-python/pychecker/pychecker-0.7.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ollie Rutherfurd <oliver@rutherfurd.net>
+# :mode=shellscript:noTabs=true:
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PyChecker is a tool for finding common bugs in python source code."
+SRC_URI="http://prdownloads.sourceforge.net/pychecker"/${A}
+HOMEPAGE="http://pychecker.sourceforge.net/"
+
+DEPEND="virtual/python"
+
+src_install(){
+ cd ${S}
+ try python setup.py install --prefix=${D}/usr
+ dodoc CHANGELOG
+ dodoc COPYRIGHT
+ dodoc KNOWN_BUGS
+ dodoc MAINTAINERS
+ dodoc README
+ dodoc TODO
+ dodoc VERSION
+}