summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2005-12-05 17:06:16 +0000
committerMarien Zwart <marienz@gentoo.org>2005-12-05 17:06:16 +0000
commit9b2cb4e855baf31b11007b6ced5d439564773ba0 (patch)
treeb2e79411d7dc54bc2302b2279c39cf56951aaba4 /dev-python
parentversion bump (diff)
downloadhistorical-9b2cb4e855baf31b11007b6ced5d439564773ba0.tar.gz
historical-9b2cb4e855baf31b11007b6ced5d439564773ba0.tar.bz2
historical-9b2cb4e855baf31b11007b6ced5d439564773ba0.zip
New ebuild.
Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/Manifest2
-rw-r--r--dev-python/vertex/ChangeLog10
-rw-r--r--dev-python/vertex/Manifest4
-rw-r--r--dev-python/vertex/files/digest-vertex-0.11
-rw-r--r--dev-python/vertex/metadata.xml18
-rw-r--r--dev-python/vertex/vertex-0.1.ebuild28
6 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index 4cc469243c3b..fe7395c52bdc 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -11,5 +11,5 @@ MD5 1dea79601dae42090b4d8f34ecfc62a7 files/twisted-2.1.0-zsh-head.patch 592
MD5 f21532a778f6bd2aa2879327084e8aa5 metadata.xml 492
MD5 b334a51322c3da107d175c71db5c5b68 twisted-1.2.0.ebuild 996
MD5 742e8cfdb91ef5a2685eb8734f209c41 twisted-1.3.0.ebuild 1061
-MD5 1a135fe89d03ff6017a6af070e8b51fb twisted-2.0.1.ebuild 2840
+MD5 fbfc15c63ae380af8cc2ee3a1feab83a twisted-2.0.1.ebuild 2840
MD5 9f32993e092061743a83df1bd882ffdb twisted-2.1.0.ebuild 3033
diff --git a/dev-python/vertex/ChangeLog b/dev-python/vertex/ChangeLog
new file mode 100644
index 000000000000..3a988cf9be3c
--- /dev/null
+++ b/dev-python/vertex/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/vertex
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/ChangeLog,v 1.1 2005/12/05 17:06:16 marienz Exp $
+
+*vertex-0.1 (05 Dec 2005)
+
+ 05 Dec 2005; Marien Zwart <marienz@gentoo.org> +metadata.xml,
+ +vertex-0.1.ebuild:
+ New ebuild.
+
diff --git a/dev-python/vertex/Manifest b/dev-python/vertex/Manifest
new file mode 100644
index 000000000000..0f57d3bd17b4
--- /dev/null
+++ b/dev-python/vertex/Manifest
@@ -0,0 +1,4 @@
+MD5 5d4f8559725030ee5c59404c8c04600b ChangeLog 336
+MD5 1f50138c0bd62cea2d15799e1cee1789 files/digest-vertex-0.1 62
+MD5 556965b9d1c03968984b4b367643abac metadata.xml 804
+MD5 de95c7cdb4a4999e6bff50ae944cc1ca vertex-0.1.ebuild 707
diff --git a/dev-python/vertex/files/digest-vertex-0.1 b/dev-python/vertex/files/digest-vertex-0.1
new file mode 100644
index 000000000000..6747151cef63
--- /dev/null
+++ b/dev-python/vertex/files/digest-vertex-0.1
@@ -0,0 +1 @@
+MD5 f2714a2ca2f97e35cdce3b995397d569 Vertex-0.1.tar.gz 102739
diff --git a/dev-python/vertex/metadata.xml b/dev-python/vertex/metadata.xml
new file mode 100644
index 000000000000..e2648708a39a
--- /dev/null
+++ b/dev-python/vertex/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>marienz@gentoo.org</email>
+</maintainer>
+<longdescription>
+ Vertex is an implementation of the Q2Q protocol (sort of like P2P,
+ but one better). There are a few moving parts in Vertex: PTCP is a
+ protocol which is nearly identical to TCP, but which runs over
+ UDP. This lets Q2Q penetrate most NAT configurations. JUICE
+ ([JU]ice [I]s [C]oncurrent [E]vents) is a very simple but immensely
+ flexible protocol which forms the basis of the high-level aspects of
+ Q2Q. vertex is a command line tool which exposes a few features
+ useful in many situations (such as registration and authentication).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/vertex/vertex-0.1.ebuild b/dev-python/vertex/vertex-0.1.ebuild
new file mode 100644
index 000000000000..a0106ce9a696
--- /dev/null
+++ b/dev-python/vertex/vertex-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/vertex/vertex-0.1.ebuild,v 1.1 2005/12/05 17:06:16 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex"
+SRC_URI="http://divmod.org/static/projects/vertex/Vertex-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/twisted-2.1
+ >=dev-python/pyopenssl-0.6
+ >=dev-libs/openssl-0.9.7
+ >=dev-python/epsilon-0.1"
+
+S="${WORKDIR}/Vertex-${PV}"
+
+DOCS="NAME.txt"
+
+src_test() {
+ trial -R vertex || die "trial failed"
+}