summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-06-29 23:24:18 +0000
committerJon Nelson <jnelson@gentoo.org>2002-06-29 23:24:18 +0000
commit8bf34f153ea23eda40647ff28cfd850edbe291fe (patch)
tree6a744ebb75e9d6bcb4b77eefed73cd3e3ad17dd2 /dev-python
parentupdate to use libtool.eclass (diff)
downloadhistorical-8bf34f153ea23eda40647ff28cfd850edbe291fe.tar.gz
historical-8bf34f153ea23eda40647ff28cfd850edbe291fe.tar.bz2
historical-8bf34f153ea23eda40647ff28cfd850edbe291fe.zip
update to new version -- closes 2719
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ReportLab/ChangeLog25
-rw-r--r--dev-python/ReportLab/ReportLab-1.14.ebuild33
-rw-r--r--dev-python/ReportLab/files/1.14/setup.py55
-rw-r--r--dev-python/ReportLab/files/digest-ReportLab-1.141
4 files changed, 106 insertions, 8 deletions
diff --git a/dev-python/ReportLab/ChangeLog b/dev-python/ReportLab/ChangeLog
index b587cbddba85..b73ed5ce275f 100644
--- a/dev-python/ReportLab/ChangeLog
+++ b/dev-python/ReportLab/ChangeLog
@@ -1,13 +1,22 @@
# ChangeLog for dev-python/ReportLab
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ChangeLog,v 1.2 2002/06/29 23:24:18 jnelson Exp $
-*ReportLab-1.11 (1 Feb 2002)
+ *ReportLab-1.14 (29 Jun 2002)
+
+ 29 Jun 2002; Jon Nelson <jnelson@gentoo.org> ReportLab-1.14.ebuild
+
+ Use distutuils for install
+ New upstream
+ Closes 2719
+ Original Author: Tod Neidt <tneidt@fidnet.com>
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ *ReportLab-1.11 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-python/ReportLab/ReportLab-1.14.ebuild b/dev-python/ReportLab/ReportLab-1.14.ebuild
new file mode 100644
index 000000000000..bb33a6da6635
--- /dev/null
+++ b/dev-python/ReportLab/ReportLab-1.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.14.ebuild,v 1.1 2002/06/29 23:24:18 jnelson Exp $
+
+#goofy tarball versioning
+vmaj=${PV%%.*}
+vmin=${PV##*.}
+
+S=${WORKDIR}/reportlab
+DESCRIPTION="Tools for generating printable PDF documents from any data source."
+SRC_URI="http://www.reportlab.com/ftp/${PN}_${vmaj}_${vmin}.tgz"
+HOMEPAGE="http://www.reportlab.com/"
+
+DEPEND=">=dev-lang/python-1.5"
+RDEPEND="${DEPEND}
+ >=sys-libs/zlib-0.95
+ dev-python/Imaging"
+SLOT="0"
+LICENSE="as-is"
+
+src_compile() {
+ cp ${FILESDIR}/${PV}/setup.py .
+ python setup.py build
+}
+
+src_install() {
+ python setup.py install --root=${D}
+ dodoc README license.txt docs/*
+}
+
+
+
+
diff --git a/dev-python/ReportLab/files/1.14/setup.py b/dev-python/ReportLab/files/1.14/setup.py
new file mode 100644
index 000000000000..aae40634a142
--- /dev/null
+++ b/dev-python/ReportLab/files/1.14/setup.py
@@ -0,0 +1,55 @@
+#! /usr/bin/env python
+
+from os import chdir, stat
+from distutils.core import setup, Extension
+
+setup (# Distribution meta-data
+ name = "ReportLab",
+ version = "1.14",
+ description = "Tools for generating printable PDF documents from any data source.",
+ author = "ReportLab Inc.",
+# author_email = "",
+ license = """
+#####################################################################################
+#
+# Copyright (c) 2000-2001, ReportLab Inc.
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification,
+# are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# * Neither the name of the company nor the names of its contributors may be
+# used to endorse or promote products derived from this software without
+# specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+# IN NO EVENT SHALL THE OFFICERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
+# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+#####################################################################################""",
+ long_description = "Tools for generating printable PDF documents from any data source.",
+ url = "http://www.reportlab.com/",
+ extra_path = "reportlab",
+ package_dir = { '':'.' },
+ packages = [ 'extensions',
+ 'graphics', 'graphics/charts', 'graphics/widgets',
+ 'lib', 'pdfbase', 'pdfgen', 'platypus',
+ 'test', 'tools', 'tools/docco', 'tools/py2pdf',
+ 'tools/pythonpoint', 'tools/pythonpoint/styles',
+ '.',
+ ],
+#./fonts
+ )
+
diff --git a/dev-python/ReportLab/files/digest-ReportLab-1.14 b/dev-python/ReportLab/files/digest-ReportLab-1.14
new file mode 100644
index 000000000000..012e2834dfd3
--- /dev/null
+++ b/dev-python/ReportLab/files/digest-ReportLab-1.14
@@ -0,0 +1 @@
+MD5 15a53dcad45bbbdf125c8ff64e535f36 ReportLab_1_14.tgz 2542003