summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:26:07 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-04-08 14:26:07 +0000
commit380feb6041ba9835c194d96dde5f8a2b61a4b5c8 (patch)
tree9c58e7dd919f8c7009a8fc4feb86511c0b0dc24e /dev-python
parentMarked ~amd64, closes bug 88270. (diff)
downloadhistorical-380feb6041ba9835c194d96dde5f8a2b61a4b5c8.tar.gz
historical-380feb6041ba9835c194d96dde5f8a2b61a4b5c8.tar.bz2
historical-380feb6041ba9835c194d96dde5f8a2b61a4b5c8.zip
initial import
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted-news/ChangeLog8
-rw-r--r--dev-python/twisted-news/Manifest4
-rw-r--r--dev-python/twisted-news/files/digest-twisted-news-0.1.01
-rw-r--r--dev-python/twisted-news/metadata.xml6
-rw-r--r--dev-python/twisted-news/twisted-news-0.1.0.ebuild31
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/twisted-news/ChangeLog b/dev-python/twisted-news/ChangeLog
new file mode 100644
index 000000000000..51b3dc29f929
--- /dev/null
+++ b/dev-python/twisted-news/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/twisted-news
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/ChangeLog,v 1.1 2005/04/08 14:26:07 lordvan Exp $
+
+ 08 Apr 2005; Thomas Raschbacher <lordvan@gentoo.org> twisted-news-0.1.0:
+ initial import
+ twisted-news was part of the main twisted release
+
diff --git a/dev-python/twisted-news/Manifest b/dev-python/twisted-news/Manifest
new file mode 100644
index 000000000000..90d9089e557e
--- /dev/null
+++ b/dev-python/twisted-news/Manifest
@@ -0,0 +1,4 @@
+MD5 01e6c3663f647ce78aa35a2348cb926b twisted-news-0.1.0.ebuild 806
+MD5 22894521731b8bf85e34e2cd931ea27e ChangeLog 365
+MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
+MD5 579c33f80328a50755d05ccd21c35c6d files/digest-twisted-news-0.1.0 69
diff --git a/dev-python/twisted-news/files/digest-twisted-news-0.1.0 b/dev-python/twisted-news/files/digest-twisted-news-0.1.0
new file mode 100644
index 000000000000..6fa4a00ff82e
--- /dev/null
+++ b/dev-python/twisted-news/files/digest-twisted-news-0.1.0
@@ -0,0 +1 @@
+MD5 9e8d4b39152f8b30d8a2255fc5ec9920 TwistedNews-0.1.0.tar.bz2 16822
diff --git a/dev-python/twisted-news/metadata.xml b/dev-python/twisted-news/metadata.xml
new file mode 100644
index 000000000000..37d1f8e02e49
--- /dev/null
+++ b/dev-python/twisted-news/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer><email>lordvan@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/twisted-news/twisted-news-0.1.0.ebuild b/dev-python/twisted-news/twisted-news-0.1.0.ebuild
new file mode 100644
index 000000000000..29ae84dd0423
--- /dev/null
+++ b/dev-python/twisted-news/twisted-news-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-news/twisted-news-0.1.0.ebuild,v 1.1 2005/04/08 14:26:07 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedNews"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="An NNTP protocol implementation with client and server(?)"
+HOMEPAGE="http://twistedmatrix.com/projects/news/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/News/0.1/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}