summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-12 11:28:30 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-12 11:28:30 +0000
commit16433eda14456bc1bd5df837af8483f3db8c53bb (patch)
tree57bd3f1b089a5ce6d307486e5a45e8a86ffecb51 /dev-python
parentversion bump (diff)
downloadhistorical-16433eda14456bc1bd5df837af8483f3db8c53bb.tar.gz
historical-16433eda14456bc1bd5df837af8483f3db8c53bb.tar.bz2
historical-16433eda14456bc1bd5df837af8483f3db8c53bb.zip
version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pmw/Manifest4
-rw-r--r--dev-python/pmw/files/digest-pmw-1.21
-rw-r--r--dev-python/pmw/pmw-1.2.ebuild56
-rw-r--r--dev-python/pythong/ChangeLog7
-rw-r--r--dev-python/pythong/Manifest4
5 files changed, 68 insertions, 4 deletions
diff --git a/dev-python/pmw/Manifest b/dev-python/pmw/Manifest
index f162cd6f6f00..0cb866d4d3f2 100644
--- a/dev-python/pmw/Manifest
+++ b/dev-python/pmw/Manifest
@@ -1,8 +1,8 @@
-MD5 f733b2e492911c93a899a4c40da08a86 ChangeLog 765
+MD5 7b9eddb0ac8312e3dbc0638c18ea836c ChangeLog 870
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
MD5 0951738b901527d2ed85af262e18938b pmw-0.8.5.ebuild 1365
MD5 e13f56c3726cb930f44578493e93529b pmw-1.1.ebuild 1458
-MD5 0fbc4a458f8ceeda27a6b3eeeb46e6db pmw-1.2.ebuild 1342
+MD5 6936a425cadbffe1e2e1a6aad1a75e79 pmw-1.2.ebuild 1349
MD5 068778ac365cde0694d7ea0c78ff939d files/digest-pmw-0.8.5 61
MD5 c9fe948e037016e8a1a6b9d57c4ae674 files/digest-pmw-1.1 59
MD5 635a2916c304a229f3e576f9413cb664 files/digest-pmw-1.2 59
diff --git a/dev-python/pmw/files/digest-pmw-1.2 b/dev-python/pmw/files/digest-pmw-1.2
new file mode 100644
index 000000000000..feafe54ff5a3
--- /dev/null
+++ b/dev-python/pmw/files/digest-pmw-1.2
@@ -0,0 +1 @@
+MD5 75c49c30595217c8d9376c36aa5426aa Pmw.1.2.tar.gz 396404
diff --git a/dev-python/pmw/pmw-1.2.ebuild b/dev-python/pmw/pmw-1.2.ebuild
new file mode 100644
index 000000000000..71969a0744cf
--- /dev/null
+++ b/dev-python/pmw/pmw-1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.2.ebuild,v 1.1 2003/10/12 11:26:31 liquidx Exp $
+
+inherit distutils python
+
+DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+HOMEPAGE="http://pmw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="MIT"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.1"
+S="${WORKDIR}/Pmw"
+
+pkg_setup() {
+ # check for Tkinter support in python
+ if ! python_mod_exists Tkinter; then
+ eerror "This package requires Tkinter support in Python. You'll need"
+ eerror "to recompile Python with:"
+ eerror "USE=\"tcltk\" emerge python"
+ die "Tkinter support missing"
+ fi
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ python_version
+
+ local pmwdir="/usr/lib/python${PYVER}/site-packages/Pmw"
+
+ local dir
+ for dir in `find . -type d` ; do
+ # Skip the doc directory
+ [ `basename "${dir}"` = "doc" ] && continue
+
+ insinto "${pmwdir}/${dir}"
+ cd "${dir}"
+ # Install all regular files in this dir
+ local file
+ for file in * ; do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ dodoc README
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
+}
diff --git a/dev-python/pythong/ChangeLog b/dev-python/pythong/ChangeLog
index 5eb499beb078..30c58f0db77a 100644
--- a/dev-python/pythong/ChangeLog
+++ b/dev-python/pythong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pythong
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/ChangeLog,v 1.3 2003/09/02 23:37:41 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythong/ChangeLog,v 1.4 2003/10/12 11:28:30 liquidx Exp $
+
+*pythong-2.1 (12 Oct 2003)
+
+ 12 Oct 2003; Alastair Tse <liquidx@gentoo.org> pythong-2.1.ebuild:
+ version bump (#29904)
*pythong-2.1_pre8 (03 Sep 2003)
diff --git a/dev-python/pythong/Manifest b/dev-python/pythong/Manifest
index 0454198d1f93..ed1a07ad0645 100644
--- a/dev-python/pythong/Manifest
+++ b/dev-python/pythong/Manifest
@@ -1,6 +1,8 @@
MD5 d376f357ed8f992af4253b88d85b688e ChangeLog 532
-MD5 a92050d24314b864ebf86eb587611a2b pythong-2.0.21.2.ebuild 1490
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
+MD5 a92050d24314b864ebf86eb587611a2b pythong-2.0.21.2.ebuild 1490
+MD5 f5a9e3ebc8b809fa2554d056da26b086 pythong-2.1.ebuild 1224
MD5 ba05e93f95f9ee60ece3790a2c9d2308 pythong-2.1_pre8.ebuild 1232
MD5 ef6104b1ca6dd2b5346eccd49c837859 files/digest-pythong-2.0.21.2 119
+MD5 fe2dcd47d67982db386e619732d04ef5 files/digest-pythong-2.1 116
MD5 f314f9b99641d7e173b29083f3ae4078 files/digest-pythong-2.1_pre8 121