summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2002-01-10 13:34:46 +0000
committerMikael Hallendal <hallski@gentoo.org>2002-01-10 13:34:46 +0000
commit054d3efa88b58afe9746ca2ae395bcc162cbfd5f (patch)
tree8cb6c2f0557505e3219552b5886b44253fc11bf3 /dev-python
parentadded, a tool that notifies you to take a break from typing every now and then (diff)
downloadhistorical-054d3efa88b58afe9746ca2ae395bcc162cbfd5f.tar.gz
historical-054d3efa88b58afe9746ca2ae395bcc162cbfd5f.tar.bz2
historical-054d3efa88b58afe9746ca2ae395bcc162cbfd5f.zip
updated Numeric with ebuild from Tod
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Numeric/Numeric-20.3.ebuild42
-rw-r--r--dev-python/Numeric/files/digest-Numeric-20.31
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/Numeric/Numeric-20.3.ebuild b/dev-python/Numeric/Numeric-20.3.ebuild
new file mode 100644
index 000000000000..e56fc1fae51c
--- /dev/null
+++ b/dev-python/Numeric/Numeric-20.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/dev-python/Numeric/Numeric-19.0.0.ebuild,v 1.3 2001/08/31 03:23:38 pm Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="numerical python module"
+SRC_URI="http://prdownloads.sourceforge.net/numpy/${P}.tar.gz"
+HOMEPAGE="http://www.pfdubois.com/numpy/"
+
+# 2.1 gave sandbox violations see #21
+DEPEND=">=dev-lang/python-2.2"
+
+src_compile() {
+
+#The ebuild as is uses a small local version of BLAS and LAPACK provided
+#by the Numeric package. If I ever get ATLAS and LAPACK ebuilds finished,
+#we'll need to edit (sed) setup.py to use the real libraries.
+
+ python setup_all.py build || die
+
+}
+
+src_install() {
+
+ python setup_all.py install --prefix=${D}/usr || die
+
+ dodoc MANIFEST PKG-INFO README
+
+#grab python verision so ebuild doesn't depend on it
+ local pv
+ pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
+#Numerical Tutorial is nice for testing and learning
+ insinto /usr/lib/python${pv}/site-packages/NumTut
+ doins Demo/NumTut/*
+
+}
+
+
+
+
diff --git a/dev-python/Numeric/files/digest-Numeric-20.3 b/dev-python/Numeric/files/digest-Numeric-20.3
new file mode 100644
index 000000000000..e0a696e56f56
--- /dev/null
+++ b/dev-python/Numeric/files/digest-Numeric-20.3
@@ -0,0 +1 @@
+MD5 99c832837d203ca8492343ff2a072e42 Numeric-20.3.tar.gz 712704