summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2004-12-11 20:25:33 +0000
committerRob Cakebread <pythonhead@gentoo.org>2004-12-11 20:25:33 +0000
commitb0a10785878572aca03fd0dcb658552fda87acdf (patch)
treeae1fbd9528355d426d456dd7981864d3362c3fbc /dev-python/wxpython
parentChanged from insinto/doins to newinitd. (diff)
downloadhistorical-b0a10785878572aca03fd0dcb658552fda87acdf.tar.gz
historical-b0a10785878572aca03fd0dcb658552fda87acdf.tar.bz2
historical-b0a10785878572aca03fd0dcb658552fda87acdf.zip
Put headers in a better place. Closes #74019
Diffstat (limited to 'dev-python/wxpython')
-rw-r--r--dev-python/wxpython/ChangeLog6
-rw-r--r--dev-python/wxpython/Manifest10
-rw-r--r--dev-python/wxpython/wxpython-2.5.3.1.ebuild11
3 files changed, 20 insertions, 7 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 336fd9547dbf..ae15b5d22222 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/wxpython
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.13 2004/11/13 23:05:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.14 2004/12/11 20:25:33 pythonhead Exp $
+
+ 11 Dec 2004; Rob Cakebread <pythonhead@gentoo.org>
+ wxpython-2.5.3.1.ebuild:
+ Put headers in a better place. Closes #74019
13 Nov 2004; Rob Cakebread <pythonhead@gentoo.org>
wxpython-2.5.3.1.ebuild:
diff --git a/dev-python/wxpython/Manifest b/dev-python/wxpython/Manifest
index ab6aa2f43b19..8c45302ad998 100644
--- a/dev-python/wxpython/Manifest
+++ b/dev-python/wxpython/Manifest
@@ -3,8 +3,8 @@ Hash: SHA1
MD5 3b06f1e87549af51d78bb7bfa33728b5 metadata.xml 182
MD5 03005fb45223144f46f174425229dd97 wxpython-2.4.2.4.ebuild 2426
-MD5 91069f4d015cd8013ba0cc7eb6c6c3e0 wxpython-2.5.3.1.ebuild 3098
-MD5 53ccea69143f2740f2052260ddb6b20a ChangeLog 8515
+MD5 e8eb335a45de49fe4e6a017dffdb148d wxpython-2.5.3.1.ebuild 3395
+MD5 02407e6bda0563c4b986c6a1d108c11b ChangeLog 8643
MD5 f959ab3869a044126ad9b66353cc68b1 wxpython-2.4.2.4-r1.ebuild 3565
MD5 d1efabd4c6bcd5edd9e61ca070e20ff0 files/digest-wxpython-2.4.2.4-r1 73
MD5 83d82d05e77457e559cf175012f538e7 files/digest-wxpython-2.5.3.1 74
@@ -14,7 +14,7 @@ MD5 960f9cf74312ac4829b96c63739fcfe9 files/wxpy-config.py 3275
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBlpMrz2gxt1z4IGYRAuz6AKCv4MH3I3twD8wP+N9SpNY6KTBuFACgzK9U
-91hcYgyejbY75RaUtBGVgjQ=
-=CyWj
+iD8DBQFBu1fJz2gxt1z4IGYRAtdQAKDN1cXccXx+aN6+uGzE25JwmZyZCQCffYPd
+1S4omYXA2NUBHMJtGIf+99s=
+=klKr
-----END PGP SIGNATURE-----
diff --git a/dev-python/wxpython/wxpython-2.5.3.1.ebuild b/dev-python/wxpython/wxpython-2.5.3.1.ebuild
index 1cda9d8807ba..1e1f4efb3eea 100644
--- a/dev-python/wxpython/wxpython-2.5.3.1.ebuild
+++ b/dev-python/wxpython/wxpython-2.5.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.5.3.1.ebuild,v 1.3 2004/11/13 23:05:05 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.5.3.1.ebuild,v 1.4 2004/12/11 20:25:33 pythonhead Exp $
inherit python wxwidgets
@@ -82,6 +82,15 @@ src_install() {
local site_pkgs=/usr/lib/python${PYVER}/site-packages
dodir ${site_pkgs}
+ if ! use gtk2; then
+ need-wxwidgets gtk || die "Emerge wxGTK with -no_wxgtk1 in USE"
+ elif use unicode; then
+ need-wxwidgets unicode || die "Emerge wxGTK with unicode in USE"
+ else
+ need-wxwidgets gtk2 || die "Emerge wxGTK with gtk2 in USE"
+ fi
+
+ mypyconf="${mypyconf} WX_CONFIG=${WX_CONFIG}"
use opengl \
&& mypyconf="${mypyconf} BUILD_GLCANVAS=1" \
|| mypyconf="${mypyconf} BUILD_GLCANVAS=0"