summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-11 22:06:29 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-11 22:06:29 +0000
commit0ddddba517a12215c8088c8b9d3642be93056aa6 (patch)
tree556aa9454ef910a75e153392ce8b20999e0b95f6 /dev-python/webtest/webtest-1.4.3-r1.ebuild
parentamd64 stable, bug #492230 (diff)
downloadhistorical-0ddddba517a12215c8088c8b9d3642be93056aa6.tar.gz
historical-0ddddba517a12215c8088c8b9d3642be93056aa6.tar.bz2
historical-0ddddba517a12215c8088c8b9d3642be93056aa6.zip
Fix tests in 1.4.3-r1, and port changes to 2.0.11. Bug 484222.
Package-Manager: portage-2.2.8/cvs/Linux x86_64 Manifest-Sign-Key: 0x0BBEEA1FEA4843A4
Diffstat (limited to 'dev-python/webtest/webtest-1.4.3-r1.ebuild')
-rw-r--r--dev-python/webtest/webtest-1.4.3-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/webtest/webtest-1.4.3-r1.ebuild b/dev-python/webtest/webtest-1.4.3-r1.ebuild
index b54ae9a194d9..ca001d5b68ab 100644
--- a/dev-python/webtest/webtest-1.4.3-r1.ebuild
+++ b/dev-python/webtest/webtest-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.4.3-r1.ebuild,v 1.9 2013/10/05 07:05:20 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.4.3-r1.ebuild,v 1.10 2014/01/11 22:06:26 floppym Exp $
EAPI=5
@@ -27,7 +27,8 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pyquery[${PYTHON_USEDEP}] )"
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_P}"
@@ -37,7 +38,13 @@ python_compile_all() {
fi
}
+src_test() {
+ DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
+}
+
python_test() {
+ # Tests raise ImportErrors with our default PYTHONPATH.
+ unset PYTHONPATH
nosetests || die "Tests fail with ${EPYTHON}"
}