summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-01-29 17:35:53 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-01-29 17:35:53 +0000
commit9ce90019e7232a4b5720c560e3a9ca4a078c993b (patch)
tree81cf0d752926ceabdd271accfff503205271deeb /dev-python/twisted
parentfixed up for ppc, set as ~ppc (diff)
downloadhistorical-9ce90019e7232a4b5720c560e3a9ca4a078c993b.tar.gz
historical-9ce90019e7232a4b5720c560e3a9ca4a078c993b.tar.bz2
historical-9ce90019e7232a4b5720c560e3a9ca4a078c993b.zip
version bump(~arch cuz of freeze)
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.0.21
-rw-r--r--dev-python/twisted/twisted-1.0.2.ebuild35
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index 8bc631321915..85ec435c60fa 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/twisted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.11 2003/01/26 19:47:08 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.12 2003/01/29 17:35:53 lordvan Exp $
+
+*twisted-1.0.2 (29 Jan 2003)
+ 29 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.2.ebuild
+ version bump (~arch cuz of freeze)
*twisted-1.0.2_alpha4 (23 Jan 2003)
23 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org>: twisted-1.0.2_alpha4.ebuild
diff --git a/dev-python/twisted/files/digest-twisted-1.0.2 b/dev-python/twisted/files/digest-twisted-1.0.2
new file mode 100644
index 000000000000..658bb5620a2c
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.0.2
@@ -0,0 +1 @@
+MD5 35363c42355b7b493531f7279bebe08c Twisted-1.0.2.tar.bz2 3862482
diff --git a/dev-python/twisted/twisted-1.0.2.ebuild b/dev-python/twisted/twisted-1.0.2.ebuild
new file mode 100644
index 000000000000..9d0d927b5208
--- /dev/null
+++ b/dev-python/twisted/twisted-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+S=${WORKDIR}/Twisted-${PV}
+DESCRIPTION="Twisted is a collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+SRC_URI="http://twisted.sourceforge.net/Twisted-${PV}.tar.bz2"
+HOMEPAGE="http://www.twistedmatrix.com/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND="virtual/python"
+RDEPEND="$DEPEND"
+KEYWORDS="~x86 ~alpha ~sparc "
+
+inherit distutils
+
+src_install() {
+ distutils_src_install
+
+ # next few lines will install docs: 9.4 megs!
+ dodir /usr/share/doc/${PF}
+ # of course it's documentation!
+ doman doc/man/*.[0-9n]
+ rm -rf doc/man # don't dupe the man pages
+ cd doc
+ cp -r . ${D}/usr/share/doc/${PF}
+ cd ../
+# should be taken care of by the distutils install
+# dodoc README TODO CREDITS
+}
+
+pkg_postinst() {
+ echo
+ einfo "Don't forget to check your .tap files if you upgrade from prior 0.99.4 otherwise you will get only errors."
+ echo
+}