summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-06-26 21:13:51 +0000
committerMarien Zwart <marienz@gentoo.org>2006-06-26 21:13:51 +0000
commitaf05ebddc97d614158bbf11716762aded3694dab (patch)
treec69f79fecb463d3ddaa040e4b421a590a56e7536 /dev-python/twisted-web
parentarm/ia64/s390/sh stable #137143 (diff)
downloadhistorical-af05ebddc97d614158bbf11716762aded3694dab.tar.gz
historical-af05ebddc97d614158bbf11716762aded3694dab.tar.bz2
historical-af05ebddc97d614158bbf11716762aded3694dab.zip
Remove twisted-web-0.5.0-r2 (the version with extra test patches for twisted-2.2.0): use twisted-2.4.0 and web 0.6.0 instead. Add new revisions with the nonworking websetroot removed.
Package-Manager: portage-2.1.1_pre1-r2
Diffstat (limited to 'dev-python/twisted-web')
-rw-r--r--dev-python/twisted-web/ChangeLog15
-rw-r--r--dev-python/twisted-web/files/digest-twisted-web-0.5.0-r33
-rw-r--r--dev-python/twisted-web/files/digest-twisted-web-0.6.0-r13
-rw-r--r--dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild32
-rw-r--r--dev-python/twisted-web/twisted-web-0.6.0-r1.ebuild30
5 files changed, 82 insertions, 1 deletions
diff --git a/dev-python/twisted-web/ChangeLog b/dev-python/twisted-web/ChangeLog
index f4f108eb58b1..17d235071537 100644
--- a/dev-python/twisted-web/ChangeLog
+++ b/dev-python/twisted-web/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-python/twisted-web
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.16 2006/06/04 02:43:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/ChangeLog,v 1.17 2006/06/26 21:13:50 marienz Exp $
+
+*twisted-web-0.6.0-r1 (26 Jun 2006)
+*twisted-web-0.5.0-r3 (26 Jun 2006)
+
+ 26 Jun 2006; Marien Zwart <marienz@gentoo.org>
+ -files/twisted-web-0.5.0-tests-2.2-compat-14780.patch,
+ -files/twisted-web-0.5.0-tests-2.2-compat-14782.patch,
+ -files/twisted-web-0.5.0-tests-2.2-compat-14786.patch,
+ -twisted-web-0.5.0-r2.ebuild, +twisted-web-0.5.0-r3.ebuild,
+ +twisted-web-0.6.0-r1.ebuild:
+ Remove twisted-web-0.5.0-r2 (the version with extra test patches for
+ twisted-2.2.0): use twisted-2.4.0 and web 0.6.0 instead. Add new revisions
+ with the nonworking websetroot removed.
04 Jun 2006; Brent Baude <ranger@gentoo.org> twisted-web-0.6.0.ebuild:
Marking twisted-web-0.6.0 ppc64 stable as a dep to avahi per Mr Bones request
diff --git a/dev-python/twisted-web/files/digest-twisted-web-0.5.0-r3 b/dev-python/twisted-web/files/digest-twisted-web-0.5.0-r3
new file mode 100644
index 000000000000..58850c744dfb
--- /dev/null
+++ b/dev-python/twisted-web/files/digest-twisted-web-0.5.0-r3
@@ -0,0 +1,3 @@
+MD5 287b9402ca99d05e6d3be99413317633 TwistedWeb-0.5.0.tar.bz2 263139
+RMD160 61829c8ae492c7cf3f43f45c70a5653584e50378 TwistedWeb-0.5.0.tar.bz2 263139
+SHA256 7d33de4924c0f7819b3ba9980461ca2bf7b8f5619f21f90755c29255570b599e TwistedWeb-0.5.0.tar.bz2 263139
diff --git a/dev-python/twisted-web/files/digest-twisted-web-0.6.0-r1 b/dev-python/twisted-web/files/digest-twisted-web-0.6.0-r1
new file mode 100644
index 000000000000..b6ef47e32fb2
--- /dev/null
+++ b/dev-python/twisted-web/files/digest-twisted-web-0.6.0-r1
@@ -0,0 +1,3 @@
+MD5 a681931d2eb747ca871ef71d8d1f5ff1 TwistedWeb-0.6.0.tar.bz2 263572
+RMD160 3884538b3d937365acbab06dbf44a7223ba019e0 TwistedWeb-0.6.0.tar.bz2 263572
+SHA256 db8cb87fd65f751a807fe22893145210235ce9fbc070e10fd827495f05babca6 TwistedWeb-0.6.0.tar.bz2 263572
diff --git a/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild b/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild
new file mode 100644
index 000000000000..62972be2a3ae
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.5.0-r3.ebuild,v 1.1 2006/06/26 21:13:50 marienz Exp $
+
+MY_PACKAGE=Web
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sh ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2
+ <dev-python/twisted-2.4"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-root-skip.patch"
+ epatch "${FILESDIR}/${P}-tests-2.2-compat.patch"
+}
+
+src_install() {
+ twisted_src_install
+
+ # Get rid of the main user-visible bits of websetroots: the
+ # wrapper script in bin and the manpage. This leaves behind the
+ # script in scripts in site-packages. websetroot is removed
+ # entirely in upstream svn and does not work in this version.
+ rm -rf "${D}"/usr/{bin,share/man}
+}
diff --git a/dev-python/twisted-web/twisted-web-0.6.0-r1.ebuild b/dev-python/twisted-web/twisted-web-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..a495017bf7fa
--- /dev/null
+++ b/dev-python/twisted-web/twisted-web-0.6.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-web/twisted-web-0.6.0-r1.ebuild,v 1.1 2006/06/26 21:13:50 marienz Exp $
+
+MY_PACKAGE=Web
+
+inherit twisted eutils
+
+DESCRIPTION="Twisted web server, programmable in Python"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+DEPEND=">=dev-python/twisted-2.4"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.5.0-root-skip.patch"
+}
+
+src_install() {
+ twisted_src_install
+
+ # Get rid of the main user-visible bits of websetroots: the
+ # wrapper script in bin and the manpage. This leaves behind the
+ # script in scripts in site-packages. websetroot is removed
+ # entirely in upstream svn and does not work in this version.
+ rm -rf "${D}"/usr/{bin,share/man}
+}