summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-11-12 00:51:50 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-11-12 00:51:50 +0000
commite316f866e9183d834a26ad6c4f1c4fbdd9c8659d (patch)
treef60ebc79b92dd95ec1aa6456b9ce01d7574a1628 /dev-python/pyxmms
parentversion bump, cleanups (diff)
downloadhistorical-e316f866e9183d834a26ad6c4f1c4fbdd9c8659d.tar.gz
historical-e316f866e9183d834a26ad6c4f1c4fbdd9c8659d.tar.bz2
historical-e316f866e9183d834a26ad6c4f1c4fbdd9c8659d.zip
version bump, cleanups
Diffstat (limited to 'dev-python/pyxmms')
-rw-r--r--dev-python/pyxmms/Manifest6
-rw-r--r--dev-python/pyxmms/files/digest-pyxmms-2.011
-rw-r--r--dev-python/pyxmms/pyxmms-1.07.ebuild4
-rw-r--r--dev-python/pyxmms/pyxmms-2.01.ebuild28
4 files changed, 34 insertions, 5 deletions
diff --git a/dev-python/pyxmms/Manifest b/dev-python/pyxmms/Manifest
index c5b9874aa484..72427bbd5f1c 100644
--- a/dev-python/pyxmms/Manifest
+++ b/dev-python/pyxmms/Manifest
@@ -1,8 +1,8 @@
-MD5 da43783e583a4088a6014c01db24c10b ChangeLog 618
+MD5 780a791174bced55aa0d051a42ba9f2c ChangeLog 809
MD5 72449c562b30ea2bb3f5570423673e8b metadata.xml 178
MD5 6be8474111acece0d0fda3bb95407793 pyxmms-1.06.ebuild 743
-MD5 f9d653bfe6a5849a29c082e19874097c pyxmms-1.07.ebuild 742
-MD5 9681b852f5c5b4c1d89e5925efa3758d pyxmms-2.01.ebuild 742
+MD5 f995768677a2c32141512cd174ba4adc pyxmms-1.07.ebuild 744
+MD5 2a2896ee52f94601eca3d5cf2d7f6841 pyxmms-2.01.ebuild 750
MD5 0504b079041c2a77e5b46ca6fdf3eab1 files/digest-pyxmms-1.06 62
MD5 e045a62bba6751534024556bc39282e2 files/digest-pyxmms-1.07 63
MD5 be942fd3af551a40337b4c27fbd80fce files/digest-pyxmms-2.01 63
diff --git a/dev-python/pyxmms/files/digest-pyxmms-2.01 b/dev-python/pyxmms/files/digest-pyxmms-2.01
new file mode 100644
index 000000000000..30c0acdaba9f
--- /dev/null
+++ b/dev-python/pyxmms/files/digest-pyxmms-2.01
@@ -0,0 +1 @@
+MD5 e3fe0e45a10042f1b1233a2d8a72e901 pyxmms-2.01.tar.bz2 38201
diff --git a/dev-python/pyxmms/pyxmms-1.07.ebuild b/dev-python/pyxmms/pyxmms-1.07.ebuild
index a1344966e29a..ec3c4ebac66a 100644
--- a/dev-python/pyxmms/pyxmms-1.07.ebuild
+++ b/dev-python/pyxmms/pyxmms-1.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxmms/pyxmms-1.07.ebuild,v 1.2 2003/09/30 21:40:35 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxmms/pyxmms-1.07.ebuild,v 1.3 2003/11/12 00:51:44 liquidx Exp $
inherit distutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.via.ecp.fr/~flo/2002/PyXMMS/dist/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
IUSE=""
DEPEND=">=dev-lang/python-2.2.2"
diff --git a/dev-python/pyxmms/pyxmms-2.01.ebuild b/dev-python/pyxmms/pyxmms-2.01.ebuild
new file mode 100644
index 000000000000..ac3d7268aaa6
--- /dev/null
+++ b/dev-python/pyxmms/pyxmms-2.01.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxmms/pyxmms-2.01.ebuild,v 1.1 2003/11/12 00:51:45 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to XMMS"
+HOMEPAGE="http://www.via.ecp.fr/~flo/2002/PyXMMS/xmms.html"
+SRC_URI="http://www.via.ecp.fr/~flo/2002/PyXMMS/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.2.2
+ >=media-sound/xmms-1.2.7-r18"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+PYTHON_MODNAME="xmms"
+
+src_unpack() {
+ unpack ${A}
+ # fix the install prefix in setup.cfg
+ sed -e 's:/usr/local:/usr:' -i ${S}/setup.cfg || die "patching setup.cfg failed"
+}