summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-09-24 20:36:49 +0000
committerJon Nelson <jnelson@gentoo.org>2002-09-24 20:36:49 +0000
commit8858746e19a9a60958479b90891c1b1b8f1fb0f3 (patch)
tree23b5443dd2707bda43662e756f8e1695506dc6c0 /dev-python/python-ldap
parentremoved ancient mask (diff)
downloadhistorical-8858746e19a9a60958479b90891c1b1b8f1fb0f3.tar.gz
historical-8858746e19a9a60958479b90891c1b1b8f1fb0f3.tar.bz2
historical-8858746e19a9a60958479b90891c1b1b8f1fb0f3.zip
commit fix for 8278
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog7
-rw-r--r--dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05-r11
-rw-r--r--dev-python/python-ldap/python-ldap-2.0.0_pre05-r1.ebuild28
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index 6bf4de46fb97..2b085b20829b 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-ldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.2 2002/08/02 02:12:11 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.3 2002/09/24 20:36:49 jnelson Exp $
+
+*python-ldap-2.0.0pre05-r1 (24 Sep 2002)
+ 24 Sep 2002; Jon Nelson <jnelson@gentoo.org> python-ldap-2.0.0_pre05-r1.ebuild:
+ Fix for bug 8278
+ Thanks to oliver at rutherfurd.net (Ollie Rutherfurd)
*python-ldap-2.0.0pre05 (1 Aug 2002)
diff --git a/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05-r1 b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05-r1
new file mode 100644
index 000000000000..a0023f32cbb7
--- /dev/null
+++ b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05-r1
@@ -0,0 +1 @@
+MD5 8de6fb19e415a84e1cfc73264c0573df python-ldap-2.0.0pre05.tar.gz 46111
diff --git a/dev-python/python-ldap/python-ldap-2.0.0_pre05-r1.ebuild b/dev-python/python-ldap/python-ldap-2.0.0_pre05-r1.ebuild
new file mode 100644
index 000000000000..e7f8baca547e
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.0.0_pre05-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.0.0_pre05-r1.ebuild,v 1.1 2002/09/24 20:36:49 jnelson Exp $
+
+VERSION="2.0.0pre05"
+S=${WORKDIR}/${PN}-${VERSION}
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/python-ldap/python-ldap-${VERSION}.tar.gz"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=net-nds/openldap-2.0.11"
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="public-domain" # NOTE: win32 section is under questionable license
+KEYWORDS="x86 sparc sparc64"
+
+inherit distutils
+
+src_compile() {
+ mv setup.cfg setup.cfg.orig
+ sed -e "s|/usr/local/openldap2/lib|/usr/lib|" \
+ -e "s|/usr/local/openldap2/include|/usr/include|" \
+ -e "s|libs = ldap lber|libs = ldap lber resolv|" \
+ setup.cfg.orig > setup.cfg || die
+
+ distutils_src_compile
+}