summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-06-21 10:32:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-06-21 10:32:45 +0000
commita1bf42504577a42def8a7b1cb34809a9941148fd (patch)
tree10a917f2b163588867b325727fa76d4141d74933 /dev-python/pysvn
parentVersion bump (diff)
downloadhistorical-a1bf42504577a42def8a7b1cb34809a9941148fd.tar.gz
historical-a1bf42504577a42def8a7b1cb34809a9941148fd.tar.bz2
historical-a1bf42504577a42def8a7b1cb34809a9941148fd.zip
Bump to 1.7.0, fixes bug #274848
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog7
-rw-r--r--dev-python/pysvn/Manifest4
-rw-r--r--dev-python/pysvn/pysvn-1.7.0.ebuild87
3 files changed, 96 insertions, 2 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index d26a318ba19d..a9d066ca66b8 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pysvn
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.1 2009/04/01 14:57:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/ChangeLog,v 1.2 2009/06/21 10:32:45 patrick Exp $
+
+*pysvn-1.7.0 (21 Jun 2009)
+
+ 21 Jun 2009; Patrick Lauer <patrick@gentoo.org> +pysvn-1.7.0.ebuild:
+ Bump to 1.7.0, fixes bug #274848
*pysvn-1.6.3-r1 (01 Apr 2009)
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index e99f51a9dae2..d50663251333 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,5 +1,7 @@
AUX skip-root-test.patch 1206 RMD160 3e0b72a1b15b59ace598501b6a157b6ea79244bb SHA1 72463d4698e488b6dd49ae15372c42ea7aa5096d SHA256 3e57b9a525b19561d34b666b690c9fa46a7d8817f7eeb9a8b3d6515f8bfabf31
DIST pysvn-1.6.3.tar.gz 310832 RMD160 aa2b1e02606fc01825eb8d35544863bf93f3ba88 SHA1 bcbc1313a0e832364bff87088e18b2bf1e6598c1 SHA256 85f514b98a5bc9e90c45e8d464940da20be3b2a43b7503fe3337863481918708
+DIST pysvn-1.7.0.tar.gz 324484 RMD160 e343fd373559d138e7b8414034527a3721566594 SHA1 96f5217e7d74dbb2eee52e490e79d97b3959b0f0 SHA256 55ae53e2e05fc7099c329a08f13a9b5d216b620cdba9f4036e3de0115601f505
EBUILD pysvn-1.6.3-r1.ebuild 2130 RMD160 465a475485b40123fab0523bd3f978a2d7bfe2ef SHA1 79c89ab3fed186d522c3087f5d01434e52075873 SHA256 a9d6df7703a2da3456c38ceae4d591eecab5b02831156622637b7a72b4261bf1
-MISC ChangeLog 482 RMD160 506a0d176801ad5fd77b4dac291a247da9e92a0f SHA1 d4daa31dbb43aeb855675b53ad4f9ad4a897d892 SHA256 a3e3385bf7a8e5af70d4d5aba4c06c416bf7e51411982d957df2c4caa436b970
+EBUILD pysvn-1.7.0.ebuild 2127 RMD160 82c48dfe7cd6d3dd4af47b611c36f9c25d1ee324 SHA1 a0ace66e217f2079438483156a24b86e8c2c0ae9 SHA256 2b4aa27e3fc288c17e5d65bee761487af934e77ed66f0268d35a79569573a374
+MISC ChangeLog 617 RMD160 1b71b6fa9cfb3efb75cda3676206b22e6148ad44 SHA1 6039c81bb2cb67ee12ce0c08594ec0b3c4ce54b2 SHA256 a3d9be846d70cd97b61ec9f156ab50b58484e33bf29998eedcbda8e9309f1567
MISC metadata.xml 160 RMD160 e730f96ab97c5be577a6d6d05f04990374a0dffb SHA1 2aa5e6be9c265c0e7bceb78ee9fd20df5f818e36 SHA256 6cd954a9de2307c57d32b25fa3599dee2908a4ddc6a98594f593d53577307a3a
diff --git a/dev-python/pysvn/pysvn-1.7.0.ebuild b/dev-python/pysvn/pysvn-1.7.0.ebuild
new file mode 100644
index 000000000000..01e778319cc6
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.7.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysvn/pysvn-1.7.0.ebuild,v 1.1 2009/06/21 10:32:45 patrick Exp $
+
+inherit eutils python toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.barrys-emacs.org/source_kits/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-util/subversion"
+# >=dev-python/pycxx-5.5.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/Source"
+
+src_unpack() {
+ python_version
+
+ unpack ${A}
+
+ # skip test test-06 if executed as root otherwise it will fail
+ cd "${S/Source/}"
+ epatch "${FILESDIR}/skip-root-test.patch"
+
+ cd "${S}"
+
+ # since pysvn-1.6.3: These sources are not compatible with python =< 2.5
+ # run the backport command to fix
+ if [[ $PYVER_MAJOR -eq 2 ]] && [[ $PYVER_MINOR -lt 6 ]]; then
+ einfo "prepare sources for python prior 2.6"
+ python setup.py backport || die "backport failed"
+ fi
+
+ # needed to generate the Makefile
+ python setup.py configure || die "configure failed"
+
+ # we want our CFLAGS as well
+ sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -e "/^CCC=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -i Makefile \
+ || die "sed failed in Makefile"
+}
+
+src_test() {
+ vecho ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ emake test || die "test-pysvn.so failed"
+ emake -C ../Tests || die "test failed"
+ vecho ">>> Test phase [none]: ${CATEGORY}/${PF}"
+}
+
+src_install() {
+ local sitedir="$(python_get_sitedir)/${PN}"
+
+ cd pysvn/
+
+ exeinto ${sitedir}
+ doexe _pysvn*.so || die "doexe failed"
+ insinto ${sitedir}
+ doins __init__.py || die "doins failed"
+
+ cd ../
+
+ if use doc; then
+ dohtml -r ../Docs/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc ../Examples/Client/* || die "dodoc examples failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(python_get_sitedir)/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "$(python_get_sitedir)/${PN}"
+}