summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-04 20:15:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-04 20:15:35 +0000
commite4ae23193c1afb17a4d5beaa59ef20995b843c70 (patch)
tree9fb1b7446c4aef09650d6555c0ca86d3e2acc800 /dev-python/pylint
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadhistorical-e4ae23193c1afb17a4d5beaa59ef20995b843c70.tar.gz
historical-e4ae23193c1afb17a4d5beaa59ef20995b843c70.tar.bz2
historical-e4ae23193c1afb17a4d5beaa59ef20995b843c70.zip
Bump to 0.18.1, remove old. Tests still fail.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/ChangeLog8
-rw-r--r--dev-python/pylint/pylint-0.14.0.ebuild78
-rw-r--r--dev-python/pylint/pylint-0.15.2.ebuild74
-rw-r--r--dev-python/pylint/pylint-0.18.1.ebuild82
4 files changed, 89 insertions, 153 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index 7efc65a61d4a..7c6b5ec1cbaa 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pylint
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.49 2009/08/25 15:53:35 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.50 2009/09/04 20:15:35 patrick Exp $
+
+*pylint-0.18.1 (04 Sep 2009)
+
+ 04 Sep 2009; Patrick Lauer <patrick@gentoo.org> -pylint-0.14.0.ebuild,
+ -pylint-0.15.2.ebuild, +pylint-0.18.1.ebuild:
+ Bump to 0.18.1, remove old. Tests still fail.
25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pylint-0.18.0.ebuild:
diff --git a/dev-python/pylint/pylint-0.14.0.ebuild b/dev-python/pylint/pylint-0.14.0.ebuild
deleted file mode 100644
index 001a897c7931..000000000000
--- a/dev-python/pylint/pylint-0.14.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.14.0.ebuild,v 1.3 2008/10/21 17:28:23 hawking Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding standard"
-SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/pylint/"
-
-IUSE="tk"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-python/logilab-common-0.21.0
- >=dev-python/astng-0.17.2
- tk? ( >=dev-lang/tk-8.4.9 )"
-
-DOCS="doc/*.txt"
-
-pkg_setup() {
- if use tk && ! built_with_use dev-lang/python tk; then
- eerror "You have USE='tk' enabled."
- eerror "Python has not been compiled with tkinter support."
- eerror "Please re-emerge python with the 'tk' USE-flag set."
- die "Missing USE-flag for dev-lang/python"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Make the test that tries to import gtk a bit less strict
- epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
-
- # Make pylint-gui print a gentoo-specific message if Tkinter is missing
- epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
-
- # Upstream fixes for tests
- epatch "${FILESDIR}/${P}-tests-typo.patch"
- epatch "${FILESDIR}/${P}-tests-reset_cache.patch"
-}
-
-src_install() {
- distutils_src_install
- # do not install the test suite (we ran it from src_test already
- # and it makes .py[co] generation very noisy because there are
- # files with SyntaxErrors in there)
- python_version
- rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
-
- doman man/pylint.1
- dohtml doc/*.html
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install:
- "${python}" setup.py install --home="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/lib/python/pylint/test"
-
- # These fail, have not been able to track down why.
- rm rpythoninput/func_unsupported_protocol.py || die "rm failed"
- rm func_test_rpython.py || die "rm failed"
- PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
- die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog 'A couple of important configuration settings (like "disable-msg")'
- elog 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
- elog 'See "pylint --help".'
-}
diff --git a/dev-python/pylint/pylint-0.15.2.ebuild b/dev-python/pylint/pylint-0.15.2.ebuild
deleted file mode 100644
index 6d7874fb2549..000000000000
--- a/dev-python/pylint/pylint-0.15.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.15.2.ebuild,v 1.1 2009/01/24 17:42:16 patrick Exp $
-
-inherit distutils eutils
-
-DESCRIPTION="PyLint is a tool to check if a Python module satisfies a coding standard"
-SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
-HOMEPAGE="http://www.logilab.org/projects/pylint/"
-
-IUSE="tk"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
-LICENSE="GPL-2"
-DEPEND=">=dev-python/logilab-common-0.21.0
- >=dev-python/astng-0.17.2
- tk? ( >=dev-lang/tk-8.4.9 )"
-
-DOCS="doc/*.txt"
-
-pkg_setup() {
- if use tk && ! built_with_use dev-lang/python tk; then
- eerror "You have USE='tk' enabled."
- eerror "Python has not been compiled with tkinter support."
- eerror "Please re-emerge python with the 'tk' USE-flag set."
- die "Missing USE-flag for dev-lang/python"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Make the test that tries to import gtk a bit less strict
- epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
-
- # Make pylint-gui print a gentoo-specific message if Tkinter is missing
- epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
-}
-
-src_install() {
- distutils_src_install
- # do not install the test suite (we ran it from src_test already
- # and it makes .py[co] generation very noisy because there are
- # files with SyntaxErrors in there)
- python_version
- rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
-
- doman man/pylint.1
- dohtml doc/*.html
-}
-
-src_test() {
- # The tests will not work properly from the source dir, so do a
- # temporary install:
- "${python}" setup.py install --home="${T}/test" || die "test copy failed"
- # dir needs to be this or the tests fail
- cd "${T}/test/lib/python/pylint/test"
-
- # These fail, have not been able to track down why.
- rm rpythoninput/func_unsupported_protocol.py || die "rm failed"
- rm func_test_rpython.py || die "rm failed"
- PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
- die "tests failed"
- cd "${S}"
- rm -rf "${T}/test"
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- elog 'A couple of important configuration settings (like "disable-msg")'
- elog 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
- elog 'See "pylint --help".'
-}
diff --git a/dev-python/pylint/pylint-0.18.1.ebuild b/dev-python/pylint/pylint-0.18.1.ebuild
new file mode 100644
index 000000000000..351747afe33c
--- /dev/null
+++ b/dev-python/pylint/pylint-0.18.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.18.1.ebuild,v 1.1 2009/09/04 20:15:35 patrick Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils python
+
+DESCRIPTION="a tool to check if a Python module satisfies a coding standard"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+SRC_URI="ftp://ftp.logilab.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples html test tk"
+
+DEPEND=">=dev-python/logilab-common-0.38
+ >=dev-python/astng-0.19.0"
+RDEPEND="${DEPEND}
+ dev-lang/python[tk?]"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_test() {
+ testing() {
+ local lpath="${T}/test/lib/python"
+ local tpath=""
+
+ rm -fr "${lpath}"
+
+ # Create testdir and copy pylint into it for testing purpose.
+ mkdir -p "${lpath}/logilab" || die
+ PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${T}/test" || die "test copy failed"
+
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN}" ]]; then
+ tpath="${lpath}/${PN}"
+ else
+ tpath="${lpath}/${P}-py${PYTHON_ABI}.egg/${PN}"
+ fi
+
+ # Copy pylint unittest and logilab-{common,astng} into our temporary test
+ # dir.
+ cp -r test/ ${tpath} || die "copy tests failed"
+ cp -r "$(python_get_sitedir)/logilab/"{common,astng} "${lpath}/logilab" || die "copying logilab-{common,astng} failed!"
+
+ pushd "${tpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" pytest -v || die "tests failed"
+ popd >/dev/null || die
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman man/{pylint,pyreverse}.1 || die "doman failed"
+ dodoc doc/FAQ.txt || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/*.txt || die "dodoc failed"
+ fi
+
+ if use html; then
+ dohtml doc/*.html || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc failed"
+ fi
+}
+
+pkg_postinst() {
+ if ! built_with_use dev-lang/python tk; then
+ ewarn "dev-lang/python has been built without tk support,"
+ ewarn "${PN}-gui doesn't work without Tkinter so if you really need it"
+ ewarn "re-install dev-lang/python with tk useflag enabled."
+ fi
+}